Using PageDown key jumps strangely when browsing. No problem when mouse is used.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: prikryl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090802 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090802 Minefield/3.6a1pre (.NET CLR 3.5.30729)

When browsing the HTML document---BuildLog generated by Microsoft Visual Studio (2005), C++ ---I have used PageDown key. It seems to move by pages first. Then it jumps to some position farther than expected. After that, I cannot move down any more (the slider is shows that I am in about half of the document having a lot of "pages" before and after the position. It seems as if it was painted twice. Firstly, the expected position is displayed, but then the browser immediately jumps back and the same fragment of the document is displayed again and again. It is independent on current width and height of the window. It seems as if some pattern in the doc caused the behaviour.

I can send the HTML document if needed (about 5 KB zipped).

Reproducible: Always

Steps to Reproduce:
1. Focus to the browsing pane.
2. Go to the top of the document.
3. Press PageDown key repeatedly.
Actual Results:  
Stops moving at some position.

Expected Results:  
Display the next fragment of the document.

When tried PageUp, it behaved similarly when (not always) going up.
(Reporter)

Comment 1

9 years ago
Created attachment 392699 [details]
The mentioned Build Log in the HTML form.

The zip contains the HTML file that was used when the bug was observed. Viewed as a local file.
(Reporter)

Comment 2

9 years ago
The same behaviour can be observed with current Firefox 3.5.2 -- Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729).

Further observation: when the PageUp/PageDown keys are used to cause the behaviour (browser window stops at some position) it moves after pressing Up or Down key on the keyboard. However, it jumps more than expected, strangely.

Comment 3

7 years ago
I tried to reproduce this with Firefox 3.6.24 on Fedora 14 with the testcase from comment 1.
I cannot reproduce (everything working as expected), hence closing as WORKSFORME.

Please reopen if this still happens for you with a recent Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.