Restart needed for localized folder name (Drafts/Junk/Sent/Templates/Archives name in folderpane tree) - IMAP only

RESOLVED FIXED in Thunderbird 3.0b4

Status

Thunderbird
Folder and Message Lists
P2
normal
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({l12y, regression})

unspecified
Thunderbird 3.0b4
l12y, regression
Dependency tree / graph
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
When connecting to an existing imap server w/ a new profile, we need to display the localized names of the special folders we recognize immediately, before a restart.
Flags: blocking-thunderbird3?
Just to clarify in the subject that this is imap only - bug 467527 fixed the rest of the cases.
Summary: Restart needed for localized folder name (Drafts/Junk/Sent/Templates/Archives name in folderpane tree) → Restart needed for localized folder name (Drafts/Junk/Sent/Templates/Archives name in folderpane tree) - IMAP only

Updated

8 years ago
Flags: blocking-thunderbird3? → blocking-thunderbird3+
(Assignee)

Comment 2

8 years ago
this is turning out to be a bit complicated - I have a patch in my tree that seems like it should work, and I think it does in some situations. But it does not work in the following situation:

1. Use the new autoconfig wizard to setup your server.
2. Have a server with a non-blank default namespace (e.g., Inbox.)

I believe the verifyLogon url we run from the autoconfig wizard leaves the server in a partly initialized state, or leaves the connection we've run in a somewhat unexpected state. In any case, the default namespace ("") has not been cleared from the host session list entry for that server, so we don't recognize the existing Sent folder as matching the sent folder fcc pref, because the former ends with "Inbox/Sent" and the latter just "Sent". We have code that corrects this, but it relies on the namespace to be set correctly.
(Assignee)

Comment 3

8 years ago
Also, the verify logon url does a namespace command but doesn't do folder discovery. I don't see why that should cause problems, but it might be an issue. So I'm going to try to first stop it from doing that and see if that helps.
(Assignee)

Comment 4

8 years ago
Created attachment 394579 [details] [diff] [review]
proposed fix

This should fix it. I think this may also help with some goofiness that occurs on the first use of an account after doing quick setup, because if the namespace isn't set correctly, various things like creating new folders or selecting existing folders may not work (all fixed by doing a restart).
Attachment #394579 - Flags: superreview?(bugzilla)
Attachment #394579 - Flags: review?(bugzilla)
(Assignee)

Updated

8 years ago
Status: NEW → ASSIGNED
Whiteboard: [has patch for review standard8]

Updated

8 years ago
Blocks: 511090

Updated

8 years ago
Whiteboard: [has patch for review standard8] → [has patch for review standard8][no l10n impact]
Attachment #394579 - Flags: superreview?(bugzilla)
Attachment #394579 - Flags: superreview+
Attachment #394579 - Flags: review?(bugzilla)
Attachment #394579 - Flags: review+
Whiteboard: [has patch for review standard8][no l10n impact] → [no l10n impact][ready to land]
(Assignee)

Comment 5

8 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: [no l10n impact][ready to land] → [no l10n impact]
You need to log in before you can comment on or make changes to this bug.