If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox causes cpu to go 100% when java chart is displayed on a separate tab

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Charles, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

I notice when http://www.prophet.net/analyze/javacharts.jsp is active but idle on a separate page, and then I go to another tab to browse or read, Firefox goes to 100% cpu.

Reproducible: Sometimes

Steps to Reproduce:
My firefox is 3.5.1
1.one browser navigate to http://www.prophet.net/analyze/javacharts.jsp
2. in http://www.prophet.net/analyze/javacharts.jsp, bring up intc chart
3.in another tab navigate to www.wsj.com
4. in another tab navigate to google and do some search
5. when cpu goes to 100%, you come back to java chart and cpu goes back down to 10%.
When you go to other tab like yahoo email, cpu goes to 100% again.  The only way I could resolve is to close java chart tab.
5. toggle tabs between #2 and #4 will cause cpu to go 100%
Actual Results:  
cpu goes to 100%

Expected Results:  
cpu not affected by java chart when I navigate to other tabs

I didn't remember having this issue in 3.5.
IE 8 doesn't have this issue.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090731 Shiretoko/3.5.3pre

This works fine for me. In fact CPU doesn't do nearly anything on this page; stays around 10% or less.
This bug looks like Bug 473580 but should be fixed in the version you're using.

Can you retest in safe-mode / with a new profile?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
Component: Extension Compatibility → General
QA Contact: extension.compatibility → general
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

8 years ago
Thanks for asking.  Yes.  I can reproduce with the following steps in safe-mode

1. Don't checkbox anything in safe mode window and click continue in safe mode
2. navigate to http://www.prophet.net/analyze/javacharts.jsp in the first tab
3. click Detach button and enter msft in ticket and draw chart
4. then click + to open three more blank tabs
5. By 2 or 3rd blank tab, cpu should go to 100%.  Cpu comes back down if you go back to javachart tab.

I'm using 
C:\WINDOWS\system32>java -version
java version "1.5.0_19"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_19-b02)
Java HotSpot(TM) Client VM (build 1.5.0_19-b02, mixed mode, sharing)

Thanks,

Charles
(Reporter)

Comment 3

8 years ago
I just upgraded my windows sun jvm to JDK 1.6 v16 and it seems to have fixed the problem.  You can close this issue.  It it occurs again, I'll file a new bug.

Thanks,

Charles
Resolving WFM per comment 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.