Set up install URLs for Labs add-ons

VERIFIED FIXED in 5.0.9

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: rdoherty, Assigned: fligtar)

Tracking

unspecified
5.0.9

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
We're redesign the labs website and would like 'safe' urls to link to add-on xpis, the same as https://addons.mozilla.org/services/install.php?addon_id=personas , which allows us to install add-ons from 3rd party sites without users seeing a yellow warning bar.'

The add-ons we have are:
* Jetpack (https://addons.mozilla.org/en-US/firefox/addon/12025)
* Weave (https://addons.mozilla.org/en-US/firefox/addon/10868)
* Ubiquity (https://addons.mozilla.org/en-US/firefox/addon/9527)
* Prism (https://addons.mozilla.org/en-US/firefox/addon/6665)
But they are experiments -- shouldn't they get a warning?
(Reporter)

Comment 2

8 years ago
The warning isn't for 'experimental' add-ons, they are for 3rd party installation of add-ons. Since this warning is used for the latter purpose, we shouldn't be in the habit of encouraging users to install add-ons even if they get this warning.

We have it set up for Weave and Personas now, so it seems like someone was ok with this procedure in the past.
(Assignee)

Comment 3

8 years ago
Personas and Weave are already in the install service. Jetpack was just added last week and will go live with 5.0.8.

So Prism and Ubiquity are the remaining ones to be added.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 510374
(Assignee)

Comment 5

8 years ago
Also, Test Pilot (13661)
Assignee: nobody → fligtar
Target Milestone: --- → 5.0.9
(Assignee)

Comment 6

8 years ago
Created attachment 395707 [details] [diff] [review]
patch, v1
Attachment #395707 - Flags: review?(clouserw)
Summary: Setup install URLs for Labs add-ons → Set up install URLs for Labs add-ons
Attachment #395707 - Flags: review?(clouserw) → review+
(Assignee)

Comment 7

8 years ago
r49664
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED; I embedded:

https://preview.addons.mozilla.org/services/install.php?addon_id=testpilot
https://preview.addons.mozilla.org/services/install.php?addon_id=ubiquity
https://preview.addons.mozilla.org/services/install.php?addon_id=prism

into a test wiki.mozilla.org page and clicked on the links -- all gave me the installTrigger() dialog
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.