Height=100% in a table sets height to window size, not it's parent elements height.

RESOLVED INVALID

Status

()

Core
Layout
P3
normal
RESOLVED INVALID
18 years ago
17 years ago

People

(Reporter: Mike M., Assigned: karnaze (gone))

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh: check the CSS case))

(Reporter)

Description

18 years ago
Open a page with the following HTML:

<table height=100% border=1>
<tr>
 <TD bgcolor=gray valign=top height=100% >
    <TABLE height="100%">
      <tr height=100% valign=top>
        <td height=100% bgcolor=green>Height should length of entire page, not
window

screen</td>
      </tr>
     </TABLE>
  </TD>
  <td height=2000>a</td>
</tr>
</table>

Result:

The height of the green cell should extend all the way to bottom of the content.
 Instead, it seems to be set to height of the browser window

Comment 1

17 years ago
Table issue. Reassigning QA owner to chrisd.
QA Contact: petersen → chrisd

Comment 2

17 years ago
dubious test case, doesn't work at all in Nav4.  It's possible we're doing the
right thing here.
Assignee: clayton → karnaze
Target Milestone: --- → Future

Comment 3

17 years ago
Well, the 'height' attribute should actually be ignored, since 'table' doesn't 
*have* a 'height' attribute (though you can use CSS to get a similar effect).
Marking INVALID - dodgy HTML.

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Whiteboard: (py8ieh: check the CSS case)
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
QA Contact: ian → amar
You need to log in before you can comment on or make changes to this bug.