Compacting IMAP inbox causes wierd tree state and crash

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: kinmoz, Assigned: scottputterman)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is probably a tree bug .. but we'll start with mailnews.

In the 2000083004 commercial build (using the new modern skin) I'm crashing
after I compact my IMAP inbox. I have my prefs setup so that I mark messages as
deleted and have to use compact folder to actually delete them.

When I compact my inbox, all the messages I have marked for deletion disappear
in the subject pane, leaving gaps between my remaining messages. Forcing a
repaint by bringing another window in front of the subject pane and making it
visible again doesn't help. If I scroll the subject pane I crash.

Comment 1

18 years ago
I've seen general problems with gaps / white spaces between msgs in the thread 
pane and I crash when scrolling.  Not sure what the cause is.

Comment 2

18 years ago
Adding crash keyword
Keywords: crash
(Assignee)

Comment 3

18 years ago
cc'ing bienvenu.  David just fixed a local folder compact crash.  Are there
similarities in the imap code?

Comment 4

18 years ago
No, local compact is different. I bet this is the bug that Hyatt fixed today,
the crash that is, after deleting the last message in the tree and then scrolling.

Comment 5

18 years ago
I've seen something very similar to this recently (i.e. since 20000926 nightly
or so); after compacting, the message and folder panes will start to go white
when scrolled, and selecting where a message 'should' be causes a crash.  Just
Talkback'd such a crash (ID TB18222630Y) and started looking for similar ones.

May also have seen this while reading news, but I'm not positive.

Comment 6

18 years ago
the stack trace for that crash is all layout code.

Comment 7

18 years ago
It always seems to be triggered by a folder compact, though (not necessarily the
inbox).  Could compact be stomping the layout somehow (unlikely)?

Comment 8

18 years ago
I cannot reproduce on my window local branch pull on 10/16.
Kin- can you still crash it ?
(Reporter)

Comment 9

18 years ago
ftang - I switched about a month ago to the "Move to trash" model. I'll switch
back to day and see if I notice any problems.
(Assignee)

Comment 10

17 years ago
kin, any updates?
(Reporter)

Comment 11

17 years ago
I couldn't reproduce the problem at all in my Win32 11/06/00
Netscape_20000922_BRANCH debug build.

I think this is fixed.

Updated

17 years ago
Status: NEW → RESOLVED
Last Resolved: 17 years ago
QA Contact: lchiang → huang
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Marking verified worksforme based on reporter's (and others') last comments.

Comment 13

17 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.