No subject = cannot send due to enigmail

VERIFIED INVALID

Status

Thunderbird
Message Compose Window
--
major
VERIFIED INVALID
9 years ago
8 years ago

People

(Reporter: Christopher Schultz, Unassigned)

Tracking

({regression})

x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

If your message has no subject, you cannot send the message.

Reproducible: Always

Steps to Reproduce:
1. Create a new message
2. Enter a recipient
3. Press SEND

Actual Results:  
Nothing

Expected Results:  
Message is sent, or "Message has no subject: continue sending?" message.

When the subject is blank, it's as if the "Send" button (or CTRL-ENTER) does nothing at all. No error message. No nothing.
This WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3pre) Gecko/20090804 Lightning/1.0pre Shredder/3.0b4pre
(Reporter)

Comment 2

9 years ago
Okay, that's fine. I didn't try the nightlies but this bug is definitely affecting me in 3.0b3.
WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090810 Lightning/1.0pre Shredder/3.0b4pre ID:20090810161308

Comment 4

9 years ago
WFM too on linux. Some extension causing it? Check if there's anything of interest in the error console.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: regression
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

9 years ago
I am using 3.0b3, so that might be the difference (I'm not using nightlies... just the latest public beta version).

Extensions: Adblock Plus v1.1.1, DictionarySearch v3.0.0 (disabled due to incompatibility with the beta), and Enigmail v0.96a. None appear to have currently-available updates.

No output whatsoever is displayed in the error console. I cleared it, created a new message, entered a recipient, entered some junk in the body and tried to send (both using CTRL-ENTER and clicking the "Send" button): nothing at all in the error console. :(

We'll see what happens with the next public beta. If it's still not working, I'll re-open and provide whatever detail I can add.
Christopher try in safe-mode and post a feedback here.
(Reporter)

Comment 7

9 years ago
It appears that this problem is only observed when Enigmail is enabled. I'll file a bug against Enigmail, then.

Thanks for the suggestions. Marking VERIFIED INVALID.
Status: RESOLVED → VERIFIED
Resolution: WORKSFORME → INVALID
(Reporter)

Comment 8

8 years ago
FYI

This bug is being tracked over in enigmail here:
https://www.mozdev.org/bugs/show_bug.cgi?id=21469

Comment 9

8 years ago
(In reply to comment #8)
> FYI
> 
> This bug is being tracked over in enigmail here:
> https://www.mozdev.org/bugs/show_bug.cgi?id=21469

from that issue "looks like this was fixed between 0.96a and 0.97a."
Severity: normal → major
Summary: No subject = cannot send → No subject = cannot send due to enigmail
Version: unspecified → 3.0
(Reporter)

Comment 10

8 years ago
Wayne,

Why did you change the severity of this bug to MAJOR when it's not a bug with tb, but with a 3rd-party plug-in?

Comment 11

8 years ago
because impact has nothing to do with who is at fault
(Reporter)

Comment 12

8 years ago
Just to close the loop on this issue, it looks like this was fixed between 0.96a and 0.97a of Enigmail.
You need to log in before you can comment on or make changes to this bug.