Flash object does not load when the movie param uses a \ instead of a / as value

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Lochana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Build Identifier: Firefox/3.0.13 and earlier version

When open the above url in internet explorer I can see the flash image where as in Firefox I cannot see the flash image. I have very latest version of Flashes in my system. Still not able to see this image for any version of firefox.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox using the url mentioned above
2.Not able to see only flash image
3.Able to see the rest of the page as usual with IE
Actual Results:  
Not able to see the Flash Image

Expected Results:  
Should be able to see the flash Image

Comment 1

9 years ago
Seeing this issue in FF 3.5.5 on XP SP3 - changed summary to reflect result of testing.

Flash object does not load when the movie param uses a \ instead of a / as the value for the movie param. The code from the site is:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="272" height="530" id="sar_ram" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="bimages\www.shirdi-sai-baba.com.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="bimages\www.shirdi-sai-baba.com.swf" quality="high" bgcolor="#ffffff" width="272" height="530" name="sar_ram" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Changing the \ to a / for the movie param allows the flash video to load if FF 3.5. Changing the \ to a / as shown below allows teh file to load

<param name="movie" value="bimages/www.shirdi-sai-baba.com.swf" />

Firefox is making a call to http://www.shirdi-sai-baba.com/bimages%5Cwww.shirdi-sai-baba.com.swf for the flash file and getting a 404.

Page loads successfully in IE 8, Safari 4 and Chrome 3 - all on XP SP3.

Not changing status as I am unsure if this is intentional.
Summary: Not able to find the flash image in Firefox → Flash object does not load when the movie param uses a \ instead of a / as value
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

8 years ago
Created attachment 495042 [details]
sai baba image

Still not able to see the image when the url is opened in firefox. Please ref screen shot for more info

Comment 5

8 years ago
See comment 1 - I can confirm but not sure of the right component or if this is by design.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2010-12-01]
The backslash in the part of the URL makes this invalid.
The http RFC says that you have to escape the "\" and you can't use it as path separator, only "/" is valid as path separator.

Firefox is doing that, escaping the invalid backslash as %5C.
You could call it a flash plugin bug if you want because the flash plugin uses the movie parameter to generate the URL and it asks Gecko to load this URL.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.