Closed Bug 508353 Opened 13 years ago Closed 13 years ago

Artifacts with background-size: contain when resizing windows

Categories

(Core :: CSS Parsing and Computation, defect, P2)

x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 509329

People

(Reporter: cww, Assigned: Waldo)

References

()

Details

Attachments

(1 file)

Attached image screenshot
Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090804 Minefield/3.6a1pre

On the background-size demo page in the URL, resize the window to smaller than max screen width, then maximize the window.  You get artifacts (see attached screenshot).

Clicking another tab or another window is enough to force a redraw that fixes it but opening a menu doesn't.
Haven't seen on Mac, could be platform-specific.  Will try to spin up a Linux VM to test this sometime in the next couple days...
Flags: blocking1.9.2?
Can confirm on:

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre)
Gecko/20090811 Minefield/3.6a1pre
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
Duplicate of bug 509329?
Setting status from UNCONFIRMED to NEW -- I can confirm on:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20090922 Minefield/3.7a1pre

(In reply to comment #3)
> Duplicate of bug 509329?

Possibly -- the most related thing there (on Linux) seems to be 509329 comment 5.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #4)
> (In reply to comment #3)
> > Duplicate of bug 509329?
> 
> Possibly -- the most related thing there (on Linux) seems to be 509329 comment
> 5.

Sorry -- I meant "bug 509329 comment 5".
This very very very feels like the third dup of bug 509329 and bug 507550, taking on that assumption.
Assignee: nobody → jwalden+bmo
Fixed in bug 509329.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509329
You need to log in before you can comment on or make changes to this bug.