Win98,95-SSL urls with lots of gifs load very slow.

VERIFIED WORKSFORME

Status

P3
major
VERIFIED WORKSFORME
19 years ago
3 years ago

People

(Reporter: junruh, Assigned: ddrinan0264)

Tracking

(4 keywords)

1.0 Branch
x86
Windows 98
perf, platform-parity, relnote, topperf

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: relnote-user, URL)

(Reporter)

Description

19 years ago
Loading the above url took 1 minute and 57 seconds. With another new 
profile, loading http://junruh/knox/color/color.html took 7 seconds.
(Reporter)

Updated

19 years ago
Keywords: nsbeta3

Comment 1

19 years ago
marking nsbeta3- per pdt review.
Whiteboard: [nsbeta3-]
(Reporter)

Comment 2

19 years ago
*** Bug 55195 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
Umm..this should have been release noted :-( Can we still add this to the beta3
release notes?
Keywords: relnote3
(Reporter)

Comment 4

19 years ago
Release noted - "Win98- Loading of secure (https) sites with lots of picture 
files can be very slow."
Keywords: rtm

Comment 5

19 years ago
Adding Need Info and cc:ing trudelle. Is anyone working on this, or did
RelNoting for PR3 cover this?
Whiteboard: [nsbeta3-] → [nsbeta3-][Need Info]

Comment 6

19 years ago
I don't know anything about this, other than that it is still glacial in the
latest branch build on Win98.  Javi?  David?  cc lord

Comment 7

19 years ago
The stress-test page is still slow, but we won't have a low risk change any time
soon.

Changing from [need info] to [rtm-]
Whiteboard: [nsbeta3-][Need Info] → [nsbeta3-][rtm-]
The given release note seems to me to be almost certainly not what the problem 
actually is. Why pictures only, for example? I'm nominating this for 
relnote-user, but I think we need to work out exactly what's going on here.

Gerv
Whiteboard: [nsbeta3-][rtm-] → [nsbeta3-][rtm-] relnote-user

Comment 9

19 years ago
This bug makes several commercial websites I use load so slowly that the
browser appears to hang for a minute or more at a time.  I've already
seen the problem on bankamerica.com and palm.net.  It seems that this issue
could really limit the number of people who will use the browser on a daily
basis if it takes them minutes to view SSL websites they use daily.
Is there at least a workaround for this problem?
(Reporter)

Comment 10

19 years ago
The workaround is to use NT, Win2000, Linux or Mac.
Summary: Win98-SSL urls with lots of gifs load very slow. → Win98,95-SSL urls with lots of gifs load very slow.
(Reporter)

Comment 11

19 years ago
*** Bug 59190 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
I don't see this as being a problem with pages which have lots of images - I am
involved in development of a secure website here and I see this performance
problem with all pages.  In fact, if I turn off images and load the same pages
via https and http URLS there is still a difference of around 3x in the time
taken.  Of course if the page _does_ have lots of images then maybe I'm seeing
this sort of performance custard for each image.  A fairly graphical page with
maybe 30 images for buttons, spacers, rollovers and stuff that your typical web
layout designer comes up with is therefore going to take an extra 30 seconds to
load.  Not a good look.

In my tests with a P400 accessthing the same 30k page of very simple HTML across
our local 100MB LAN:
http: url takes 0.94 seconds the first time, decreasing to 0.44 seconds on
repeated refresh.

https: url takes around 5 seconds the first time, decreasing to around 1.5
seconds on repeated refresh.
(Reporter)

Comment 13

19 years ago
nsbeta1
Keywords: nsbeta1

Comment 14

18 years ago
This bug is not confined to Win98 or the mozilla code.  I can reproduce this 
bug on win98, NT, and win2000 using Netscape 4.72, Netscape 6 PR3, or recient 
Mozilla code.
Our secure pages contain 5 gif's in the headers and footers that total 16KB.  
These are the same on every page so they should be catched.
We are using Netscape Enterprise Server 3.63 on Sparcs running SunOS 5.8.  Most 
of the secure pages are JSPs being served from a Weblogic 4.52 Server.

Given that this problem has caused use to begin using IE for our development 
work, and recommend it to our customers as well, I think it would be a good 
idea to upgrade it to a higher priority.

Comment 15

18 years ago
Is the SSL connection being kept open to load all the images or is a new 
connection being created for each one? If new connections are being created, 
that might explain why it is so slow. I ask because, when I try to access an SSL 
site through our corporate firewall, I see some garbage at the top of the page 
that looks like HTTP headers. Included in the garbage is "Connection: close".
(Reporter)

Comment 16

18 years ago
*** Bug 67269 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: perf

Comment 17

18 years ago
Please fix this before .9.  I would hate to see the next netscape & 9/10ths of 
a Mozilla have this problem.  It hinders ecommerence on the Internet.  Right 
now for purchases I make, I must use IE, Netscape 4, or wait forever on Mozilla 
(and I have a P800 and a T1).  I personally think the severity & priority 
should be bumped up (and helpwanted keyword if no one is fixing right now) + a 
target milestone set.  Perhaps mozilla0.9 keyword?

Comment 18

18 years ago
Have a look at
http://banking.migrosbank.ch/demo
with mozilla0.8 and compare it to NS 4.76 or IE. No e-commerce is possible with
mozilla.

Comment 19

18 years ago
Ok we're past nsbeta's so removing those keywords. adding mozilla0.9.1 keyword.
Severity: normal → major
Keywords: nsbeta1, nsbeta3 → mozilla0.9.1
Target Milestone: --- → mozilla0.9.1

Comment 20

18 years ago
This is a dogfood bug.

THis bug makes any major e-commerece site (the secure part) unusable in mozilla.

buy.com for example:
https://www.us.buy.com/corp/support/login.asp

my p3 800 with a dsl connection chokes

Comment 21

18 years ago
Agreed, priority on this one should be bumped up.  I use Mozilla/Win98 as my
main browser and when I want to do online banking, or shop online, or whatever,
I have to grab a cup of coffee between page loads.  I couldn't see the general
public putting up with this kind of atrocious slowness in a browser.  This one
should really be fixed before the next Netscape branch...

Comment 22

18 years ago
Also, the test-case URL no longer works.
(Reporter)

Comment 23

18 years ago
The testcase works if you're inside the Netscape firewall. Here is another site 
that is slow to load - https://enigma.barclaycard.co.uk/

Updated

18 years ago
Keywords: topperf

Comment 24

18 years ago
cc self. sorry for the SPAM.

Comment 25

18 years ago
I am not if the bug is limitted to windows platforms, for I also encountered
this bug in 0.8 on FreeBSD.

Comment 26

18 years ago
since most of us are outside the firewall...

The enigma url loaded in ~35s on w2k. Assuming that it is comprable to the 
firewalled testcase, and assuming that the original report is still accurate, 
this bug is specifically for w9x performance being ~300% worse than the other 
platforms.

i tested on a 4/13-04 build that included a hacked XPFE interface which should 
hurt performance slightly (the content pane was reflowing because it wasn't 
sure about how wide it could be). this is before the psm2 landing i think.

junruh: how many of my assumptions are wrong? ddrinan: was there some specific 
flaw in NSPR or 9X winsock that caused this? and does psm2 change any of this?
Keywords: relnote3, rtm → pp, relnote
Whiteboard: [nsbeta3-][rtm-] relnote-user → relnote-user

Comment 27

18 years ago
Well I can say that since PSM2 has been added to the nightly builds performance
has gone way up.  :-)

Going to amazon.com or buy.com is much faster.  These sites were slow as hell
before.  If I was the reporter of this bug I would mark this WFM or Fixed.  Nice
fix.
(Reporter)

Comment 28

18 years ago
Marking worksforme. 
Performance of SSL on Win95,98 has increased dramatically now that PSM 2.0 is 
in the builds. I should have detailed performance numbers in the next few weeks 
comparing SSL download times on 4.77, IE 5.5, Mozilla with PSM 1.5 and Mozilla 
with PSM 2.0.

The PSM 2.0 developers mentioned yesterday that they have not yet spent time on 
speeding up SSL performance, so download times should decrease further in the 
future.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 29

18 years ago
Marking Verf. Great job! :-)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 30

18 years ago
Mass changing Security:Crypto to PSM
Component: Security: Crypto → Client Library
Product: Browser → PSM
Target Milestone: mozilla0.9.1 → ---
Version: other → 2.1
(Reporter)

Comment 31

18 years ago
Mass changing Security:Crypto to PSM

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

11 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.