Create Contributions dashboard

VERIFIED FIXED in 5.0.9

Status

P2
normal
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: osunick, Assigned: smccammon)

Tracking

unspecified
5.0.9
Dependency tree / graph

Details

Attachments

(4 attachments)

(Reporter)

Description

10 years ago
See attached for mini spec and mockup.  This should live on the statistics dashboard section and the Contributions dropdown appears for all developers.  If no contributions have been made, the section just says "You haven't received any Contributions yet."
(Reporter)

Comment 1

10 years ago
Posted image Mockup and mini spec
(Reporter)

Updated

10 years ago
Target Milestone: --- → 5.0.9
(Reporter)

Updated

10 years ago
Priority: -- → P2
->mccammos.  This is dependent on us getting stats which is 2 metrics bugs I haven't filed yet.  So...code is good, but be a bit flexible with the starting data for now.
Assignee: nobody → smccammon
(Reporter)

Updated

10 years ago
Depends on: 508973
(Reporter)

Updated

10 years ago
Depends on: 508972
(Reporter)

Comment 3

10 years ago
just talked to justin fitzhugh- this will get attention this monday.  also adding a mock for the admin version of this dashboard
(Reporter)

Comment 4

10 years ago
Posted image admin dashboard
this is viewed from the admin cp (just another box in the left nav)
(Reporter)

Comment 5

10 years ago
scott- fyi, only rows with null uuid's are completed transactions.  uuid's that aren't null are for all intents and purposes clicks where the user decided not to pay.
(Assignee)

Comment 6

10 years ago
Here is my first stab as the clock runs out. Adds to the dev-side dashboard a contribution timeplot and summary. It also uses the existing data table code already in place, but this lacks any custom formatting.

Usable but not complete (or perfect).
Attachment #395787 - Flags: review?(clouserw)
Comment on attachment 395787 [details] [diff] [review]
Basic Dev Dashboard

With or without contributions I get an alert that says "Caught exception: undefined. Details: TypeError: event.getStart() is null" when I try to view the contributions graph.

Other than that this appears to work fine.
Attachment #395787 - Flags: review?(clouserw) → review-
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> With or without contributions I get an alert that says "Caught exception:
> undefined. Details: TypeError: event.getStart() is null" when I try to view the
> contributions graph.

It seems that IE has a few problems with the dashboard javascript - even on production. I'll look into it.
(Assignee)

Comment 9

10 years ago
Filed bug 511927 for plot errors in IE since this affects more than this bug.
I wasn't using IE but scott says he can't reproduce this.  Let's land on preview and see what happens there.  I might just have broken data.
(Assignee)

Comment 11

10 years ago
Committed in r49737.

I blame timeplot for not gracefully handling any issues with the many data requests it makes. We shall see.
Reproduced the error on preview.  Scott is fixing
(Assignee)

Comment 13

10 years ago
The timeplot alert issue was reproducible when a contribution had a null amount. Any successful and valid contribution will have a positive amount so we can safely exclude records with null or negative amounts.
Attachment #395949 - Flags: review?(clouserw)
Comment on attachment 395949 [details] [diff] [review]
Ignore NULL amounts

I'll r+ but do you know why we have null amounts in the db in the first place?  Is that just left over data from somewhere?
Attachment #395949 - Flags: review?(clouserw) → review+
(Assignee)

Comment 15

10 years ago
(In reply to comment #14)
> (From update of attachment 395949 [details] [diff] [review])
> I'll r+ but do you know why we have null amounts in the db in the first place? 
> Is that just left over data from somewhere?

Null is the default value when the user doesn't choose the suggested amount. Only Paypal knows the final amount, so we depend on metrics to fill things in later.
(Assignee)

Comment 16

10 years ago
A point that I should have clarified earlier: The current implementation
assumes contribution stats are viewing only by owners and admins - even for
add-ons with public stats.

Wil thought we might want a note to explain who can/can't see this data. A
footnote below the contribution summary table would probably work.

Was this assumption correct? If not it is trivial to make public for public
stat add-ons.
(Assignee)

Comment 17

10 years ago
Ignore NULL patch added in r49752.
I think it's a good assumption (I was actually thinking we'd need to file a bug to make it an option, but this works).  I think /statistics/settings/$id would be the page to put a note on.  Just something simple like "contributions are only ever shown to authors and site administrators"  or something.
(Assignee)

Comment 19

10 years ago
Resolving as fixed for 5.0.9, and filed bug 511996 for implementation of remaining features.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED -- this is in (I've been testing it and filing/verifying bugs accordingly.)
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.