If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Server busy" pop-under message on start-up with localhost on WAMP server

RESOLVED INVALID

Status

()

Firefox
General
--
minor
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Reggie Thomson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Previous session of Firefox includes a http://localhost/ page (e.g. http://localhost/phpmyadmin/) on Windows Vista with WAMP 2.0 server running.

When Firefox is shut down and restarted (with WAMP server running), it seems to hang, unable to display any pages. 

To continue, Firefox has to be minimised and then brought back to full-screen to display the "pop-under" message box: (title:) 'Server busy' (Message:) 'This action cannot be completed because the "[title of last opened page] - Mozilla Firefox" program is not responding. Choose "Switch To" and correct the problem.'

When you choose "Switch To" Firefox proceeds to display the pages and runs as normal.

Reproducible: Always

Steps to Reproduce:
1. Run WAMP 2.0 server
2. Start Firefox
3. Open e.g. http://localhost/phpmyadmin/
4. Close Firefox (with session saved option)
5. Open Firefox (appears to hang)
6. Minimise Firefox
7. Restore Firefox or Maximise Firefox
8. Click "Switch To" on the message box


Expected Results:  
No pop-under message. Pop-up or no message at all (best)
(Reporter)

Comment 1

8 years ago
Sorry, not happening every time - may be due to the MySQL server part of WAMP not being up or not responding fast enough when lots of programs are started after a re-boot.
Please try http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

8 years ago
My apologies for a misdiagnosis.

It's due to Foxit pdf reader. It happens when there is a pdf document on a tab on start up. If there isn't a pdf document open, Firefox starts normally. When a pdf document link is selected for the first time, the "Switch To" message appears (as a pop-up). 

Probably not a Firefox problem.
(Reporter)

Comment 4

8 years ago
This bug has now been reported to foxitsoftware.com, Ticket No. 14149. I have therefore put the status of this to "Resolved" - "Invalid"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.