Closed Bug 508543 Opened 11 years ago Closed 11 years ago

text-transform style doesn't apply while searching

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 12460

People

(Reporter: seejay.11, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I've noticed that CSS styles affect searches, in that if it's not displayed in CSS then it can't be searched for.
With case-sensitive searches, the text-transform style (uppercase, lowercase, etc) doesn't apply, even though the visible text looks uppercase/lowercase.

Try a case-sensitive search (ctrl-f) for "navigation" on Wikipedia for an example.


Reproducible: Always

Steps to Reproduce:
1. Go to a site with text-transform styles applied to a part of text.
2. Try to do a (case-sensitive) search for what the text appears to be.

Actual Results:  
Fails to find the text in the displayed case (you have to use the case specified in the source code)

Expected Results:  
The text in its visible case should have been found.
To clarify - http://en.wikipedia.org/wiki/HMS_Boadicea_%281908%29 - hit ctrl-f - select case sensitive text - enter 'navigation' - and it doesn't match - Navigation does, which is not the apparant text.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 12460
You need to log in before you can comment on or make changes to this bug.