“ ” appears in some of the flag reasons in reviews pages in Czech

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Localization
P4
minor
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: fcp, Assigned: JasnaPaka)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 392724 [details]
Screenshot of https://addons.mozilla.org/cs/firefox/reviews/display/12312

I noticed just by chance that in reviews pages in Czech, two of the reasons for flagging contain the string “ ”.  I cannot read Czech but I doubt that this is a correct Czech word :)

Reproducible both in AMO 5.0.7 and in the upcoming AMO 5.0.8 on preview.addons.mozilla.org.

One way to avoid this might be to use the real no-break space (U+00A0) instead of “ ” in the strings review_flag_reason_bug_support and review_flag_reason_spam in site/app/locale/cs/LC_MESSAGES/messages.po, but I do not know if this is the correct fix.

I am unsure if this bug belongs to the Localization component.  Please change the component if necessary.
Why are there html entities in these strings anyway? And yes, if they are really necessary, stick with UTF-8 characters.
Assignee: nobody → pcvrcek
Priority: -- → P4
(Assignee)

Comment 2

8 years ago
Fixed in rev. 56915. Thanks!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
Verified fixed.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.