Closed Bug 508591 Opened 12 years ago Closed 12 years ago

Page with sprites not saved correctly

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 115107

People

(Reporter: dave, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.1) Gecko/20090714 SUSE/3.5.1-1.1 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.1) Gecko/20090714 SUSE/3.5.1-1.1 Firefox/3.5.1

Pages on windfinder.com use sprites to display weather symbols (wind and cloud). 
If I save such a page, and then reload it, these symbols are not visible.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.windfinder.com/forecast/kos or similar windfinder.com page. 
2. Notice that there are wind direction arrows and cloud cover symbols.
3. Save the page with File > Save page as ...
4. Open the saved webpage in Firefox
Actual Results:  
There are no wind or cloud symbols when viewing the saved page.

Expected Results:  
There should be - as in the original.

I've tried this in Windows too - and originally found it on my Nokia N810 which uses the MicroB (gecko) browser.

It's something to do with the way these symbols use sprites. A workround is to create a directory /grafiken/nav at root level and put the files sprite_sky.png & sprite_winddirs.gif in it. It then displays OK.

(This problem is not as trivial as it looks. When sailing I save these pages in case I cannot get internet access - and I need the wind direction!)
I see those are backgrounds given to table cells using CSS then it's bug 115107.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
You need to log in before you can comment on or make changes to this bug.