Impeded scrolling by keyboard

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Roman R., Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

I've visited many web pages on which scrolling with the keyboard is impeded by something. Essentially, content flickers but doesn't move or reverts to the original position. The page at the address mentioned above is one such page. It works fine in IE.

Reproducible: Always
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090804 Shiretoko/3.5.3pre

This works fine for me.
Version: unspecified → 3.5 Branch

Comment 2

9 years ago
works for me - 3.5.2/linux
up/down cursor keys and pageup/down
(Reporter)

Comment 3

9 years ago
OK, here's another website with the problem: http://social.expression.microsoft.com/Forums/en-US/web/thread/ff4eb226-a3ae-4363-bd0e-66ca8d601d12. The problem is noticeable when try to scroll with the keyboard after clicking inside one of the replies (but not the original post) there.
(Reporter)

Comment 4

9 years ago
And on http://social.expression.microsoft.com/Forums/en-US/web/thread/ff0716e4-bd35-4d26-a70d-7a3af4fa108a?lc=1033 the problematic behavior happens when I click inside the original post too. Note: I mean text of the post. Clicking, say, in the header of a post block doesn't trigger the problem.

Also note: when the problem is visible, content of a post scrolls slightly (by a few pixels). The behavior is exactly what would happen and be expected is the block had a scroll bar. But it doesn't. (It does in IE, by the way.)
(Reporter)

Comment 5

9 years ago
I meant to say "if the block had a scroll bar", not "is the block..."
(Reporter)

Comment 6

9 years ago
Here's another page: http://www.mydigitallife.info/2007/09/18/run-wordpress-at-top-fast-speed-by-putting-objects-and-variables-into-xcache-or-eaccelerator-cache-memory-plugin/

Load it, click arrow down and observe the page scrolling immediately to the end (it's too long for the behavior to be justified).
(Reporter)

Comment 7

9 years ago
Using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729) now.
I can only reproduce your first and last case in the caret browsing mode. 
Tools > Options > Advanced > General > Always use the cursor keys.. etc.
Pressing f7 turns in on and off.
The pages from comment 3 and 4 are indeed not scrolling but my guess is that this is caused by crappy page code.
If f7 helps then Firefox works as designed.
(Reporter)

Comment 9

9 years ago
Hmm... there must more to this. When I tries to reproduce the bug NOW, I couldn't do it. However, I rebooted my computer recently. I think I've noticed before that Firefox sometimes behaves very different before and after a restart.

I've also noticed that sometimes on some pages caret browsing mode gets activated (I see the cursor moving across the page) without any conscious actions on my part, and because I didn't know how to toggle the mode, I couldn't switch back. I will toggle the mode the next time I experience this problem and report back.

Comment 10

8 years ago
I use Windows 7 x64 and MS Natural 4000 keyboard with MS Intellitype installed (though it works a bit queer since I moved from Vista x64).

Got a similar bug. When I press PageUp, the view jumps to the end (!) of the web page. If PageUp is pressed while being at the end of the page, the page goes up a bit, then once again scrolls to the end. That was encountered while reading a book on librusec (http://lib.rus.ec/b/177375/read). I checked if it happens on other pages as well, and it does. If I use another browser (I used Google Chrome) the PageUp and PageDown keys work just fine.

Steps to reproduce:
1.Load a web page which is longer than one screen (the vertical scrollbar appears).

2.Use PageUp and/or Page Down at random. 

Summary:
=This doesn't happen at every web page. PageUp/PageDown both work fine for this bugzilla page. But it happens at librusec (http://lib.rus.ec, particularly http://lib.rus.ec/b/177375/read;).
=It has nothing (or, at most, not everything) to do with my keyboard - never noticed such glitches in OS or in another browser.

<u>Ria Klaassen (testing/triage)</u> suggested that this was caused by a mix of **** page code and Always use cursor keys... mode. Indeed it is. Turning this mode off worked for me. So this issue is actually a feature? ))
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
(Reporter)

Comment 12

7 years ago
I can't seem to reproduce the problem in 3.6.13 in safe mode. I will close this issue.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.