Closed Bug 508637 Opened 12 years ago Closed 12 years ago

Get rid of strict warning on trailing commas in object initializers (as per ES5)

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.2b1

People

(Reporter: davida, Assigned: jimb)

References

Details

Attachments

(1 file)

given:

foo = {bar: 'baz',
       tom: 'cat',
      }

me:
>>> What's the rationale for complaining
>>> about that?  I find that the trailing comma makes patches cleaner, and is
>>> less error prone (the cost of forgetting a comma is potentially large).

shaver:
>> ECMA's syntax doesn't permit a trailing comma in object initializers
>> (perhaps changed in ES5, I can't recall)

brendan:
> ES5 indeed gets rid of this obnoxious MSFT contribution to ES3. :-)
> Someone please file a bug to get rid of this strict warning.
Duplicate of this bug: 508639
Jim, Rob: this is trivial to fix and wanted for ES5 conformance.

/be
Blocks: es5
Flags: wanted1.9.2?
Assignee: general → jim
Attachment #393016 - Flags: review?(igor) → review+
http://hg.mozilla.org/mozilla-central/rev/12cc5c8c1236
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 286937
Flags: wanted1.9.2?
Target Milestone: --- → mozilla1.9.2b1
Version: unspecified → Trunk
Depends on: 685234
You need to log in before you can comment on or make changes to this bug.