Remove strict warning for trailing comma in object literals (per ES5)

VERIFIED DUPLICATE of bug 508637

Status

()

Core
JavaScript Engine
VERIFIED DUPLICATE of bug 508637
9 years ago
9 years ago

People

(Reporter: Gijs, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Per: http://groups.google.com/group/mozilla.dev.platform/browse_thread/thread/13acadc848bf612d#

Because ES5 removed the requirement for warnings/errors for trailing commas, we can remove the strict warning for people doing:

var foo = {
  bar: 'baz',
};
(Reporter)

Comment 1

9 years ago
We were all so enthusiastic - oops! :-)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 508637
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.