X server consumes ~100% of a cpu while bespin is running.

RESOLVED INVALID

Status

Skywriter
Editor
P5
major
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Fred Oliver, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.9.0.11) Gecko/2009060311 Firefox/3.0.11
Build Identifier: demo on bespin.mozilla.com as of 05-aug-2009

On linux (openSuSE 11.1, 32-bit, firefox 3.0.12)
and on solaris (nevada 116)

While running the bespin demo from bespin.mozilla.com, 'top' shows the X server consuming ~100% of a cpu, and the browser is very unresponsive.

Reproducible: Always

Steps to Reproduce:
1. from suitable system, start the demo on bespin.mozilla.com.
2.
3.
Actual Results:  
X server nearly 100% busy as long a bespin is running.

Expected Results:  
Essentially no cpu usage while idle.

Comment 1

8 years ago
This is likely the nvidia driver issue.

Comment 2

8 years ago
Oops... forgot the link: 
https://wiki.mozilla.org/Labs/Bespin/KnownIssues#Why_does_it_seem_slow_on_Linux.3F

Comment 3

8 years ago
plz let us know if fixing your driver resolved the problem
Priority: -- → P5
(Reporter)

Comment 4

8 years ago
Using command "nvidia-settings -a InitialPixmapPlacement=2" on the screen on which bespin was running improves the situation on both the linux and opensolaris systems. As noted is several other places, the command must be run each time the X server starts. In addition, the command appears to be screen specific and must be run for each screen which might use bespin (e.g. --display :0.1 on my two screen system). There appears to be no xorg.conf option by this name. 

After changing this setting, the X server consumed 20-50% of a processor (with dual core processors) while bespin is idle. It can consume much more while typing or interacting with bespin. I once did something (typing, scrolling, etc?) which got the X server stuck back at 100%, but was not able to reproduce the situation.

While the problem does not appear to be in bespin, it doesn't appear that nvidia has interest in fixing the problem. And it doesn't seem reasonable to expect all nvidia/linux users of a web site to be savvy enough to deal with the problem. Is there progress in getting bespin/firefox working around the problem? If not can bespin detect and display a helpful message to the user?

Comment 5

8 years ago
These are interesting questions, thanks for the feedback Fred. We'd gladly accept a patch that presents some kind of advisory to Linux users about this, and Linux folks should follow-up with the Firefox team on tracking this down as its a canvas-specific issue. If enough people vote on the issue or otherwise weigh in, we'll devote some of our resources to tracking it down as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

8 years ago
Fred,

Are you running the most current linux driver from nvidia? I currently no longer have this issue on my ubuntu install since I upgraded the driver. I forget the number but I think it's like 194.
(Reporter)

Comment 7

8 years ago
The boards in question are NVS 280 (on Solaris) and NVS 110M (on Linux).
The latest drivers provided by Sun and SuSE for the respective boards
are both version 96.43.11. The nVidia supplied drivers for the 110M board
(169.04 and 100.14) are almost two years old and don't even compile under 
2.6.27 kernels. (And the laptop itself is less than two years old.)
So -- best available driver. (Sigh)

Comment 8

8 years ago
Fred,

On nvidias site they have the 96.43.13 as legacy but you may be able to use the 185.18.29 drivers as well. I have been successful previously running older cards under the newer linux drivers instead of the legacy ones. Hope this may help a little.
(Reporter)

Comment 9

8 years ago
With 185.18.31 on openSuSE 11.1 with kernel 2.6.27.25-0.1:
kernel null pointer dereference.

Comment 10

8 years ago
Bespin is now very different from how it was in August. Additionally, Firefox 
3.6 is dramatically faster than 3.0. Has this situation improved since then?

Comment 11

7 years ago
ACETRANSITION

The Skywriter project has merged with Ajax.org's Ace project (the full server part of which is their Cloud9 IDE project). Background on the change is here:

http://mozillalabs.com/skywriter/2011/01/18/mozilla-skywriter-has-been-merged-into-ace/

The bugs in the Skywriter product are not necessarily relevant for Ace and quite a bit of code has changed. For that reason, I'm closing all of these bugs. Problems that you have with Ace should be filed in the Ace issue tracker at GitHub:

https://github.com/ajaxorg/ace/issues
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.