Drag doesn't work when Firefox is launched via the command line

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
3 years ago

People

(Reporter: liangzan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Hi,

I started firfox by entering the command below

/Applications/Internet/Firefox.app/Contents/MacOS/firefox-bin -no-remote -P dev 

'dev' is the name of the firefox profile.

I would highlight, and drag text from any web page. But it doesn't work. 

The commandline would show this:

2009-08-06 17:15:24.004 firefox-bin[1257:10b] CoreDragCreate error: -4960

None of the web pages allows dragging.

Reproducible: Always

Steps to Reproduce:
1 Enter this on the command line(bash or zsh) ./Applications/Internet/Firefox.app/Contents/MacOS/firefox-bin -no-remote -P dev 

dev is the firfox profile

2.Load any web page with text
3.Highlight a word. 
4.Drag it
Actual Results:  
Drag is not working.

Expected Results:  
The word is supposed to be dragged

The drag behaviour works fine if I started Firefox in normal way(clicking on the icon)
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 3

3 years ago
I believe this bug can easily be reproduced by launching firefox-bin from tmux on OS X. In particular:

- copy/paste stops working
- attempting to drag toolbar items in the "customize" dialog result in the following errors being printed in the console:

  firefox-bin[17491:507] CoreDragCreate error: -4960
  firefox-bin[17491:507] error in CoreDragDispose: -1850

This is a well-known problem with programs launched under tmux that try to interact with OS X Pasteboard Service. A quick work-around is to install a wrapper program "reattach-to-user-namespace" (brew install reattach-to-user-namespace if you're using HomeBrew) and launch firefox-bin using the wrapper:

  reattach-to-user-namespace firefox-bin -no-remote -P dev

It is described in more detail in https://github.com/ChrisJohnsen/tmux-MacOSX-pasteboard/blob/master/README.md .
You need to log in before you can comment on or make changes to this bug.