Closed Bug 50877 Opened 20 years ago Closed 20 years ago

Menu items don't work in View Source window

Categories

(SeaMonkey :: UI Design, defect, P2)

PowerPC
Mac System 8.6
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME
Future

People

(Reporter: bugzilla, Assigned: paulkchen)

References

Details

(Keywords: helpwanted, platform-parity, Whiteboard: [nsbeta3-])

...i'm unable to access any of the menu items. found this using 2000.08.30.08
opt comm bits on Mac OS 8.6.

to observe:
1. bring up either the page source or page info window (View > Page Source, Page
Info).
2. while viewing either the source or info, try to access a menu item from the
menubar. eg, File > Close, File > Open Web Location.

result: nothing happens.

i understand that the menubar was disabled for win32 and linux bits. is this
fallout due to that change? should the menubar on Mac be disabled?
Keywords: correctness
this is mac-only.
Keywords: pp
coulda sworn this used to work (possible regression?). asa, does this fail for
you too?
Keywords: nsbeta3
wait wait, so what menu should this window use? If you don't give it one, we're a 
little screwed on mac.

who "disabled this for windows and linux?" I'd like to go take them outside for a 
"lesson"
we should have menus for these windows but do not.  they are not in place.  the
mac menus should be loaded as empty until we have some real meuns I guess. 
the menubar for the source window was removed for win32 and unix...some time
ago... see comments in bug 32719: apparently, the menubar "shouldn't" be there.
It looks like the view source menu window might not have a menu bar now. It
needs one for MacOS.
->xpapps
Assignee: saari → don
Component: XP Toolkit/Widgets: Menus → XP Apps
QA Contact: jrgm → sairuh
bill, would this belong to you? if not, do hand it back to don for triage. :)
Assignee: don → law
nav triage team:
not a show stopper....
Whiteboard: [nsbeta3-]
Keywords: helpwanted
FWIW: the same is true about the menu bar when any dialog is up.
*** Bug 53088 has been marked as a duplicate of this bug. ***
adding folks from bug 53088...remove yourself if you're no longer interested or
don't want to deal with more bugmail. :)
See bug 63026 for re-adding the menus on Windows and Linux.
nav triage team:

This is bad; it's got to be fixed. Marking nsbeta1, p2, mozilla0.9
Keywords: nsbeta1
Priority: P3 → P2
Target Milestone: --- → mozilla0.9
nav triage team:

Forgot to reassign to pchen.
Assignee: law → pchen
Thing is, one of the annoying things is that Edit -> Preferences doesn't work.  
Grrrrr....Almost wrote a duplicate of this but caught myself in time.  I didn't 
pull it up in a search, just some related bugs, and I followed the bread crumb 
trail.  Anyway, Added some text to the summary.

Bugs this is related to:
bug 53088, bug 32719, bug 63026.
Summary: menubar appears active for view source/info window, but... → menubar appears active for view source/info window, but...Menu options inactive in View Source Mode
To add to Dan Lorca's comment above, nothing in the Edit menu seems to work.
(Well, Command-A works but selecting Edit->Select All doesn't)

Mozilla 0.7 (2001010816), MacOS 9.0
This depends on bug 63026 -- unless you want to correct what appears to be a
toolkit bug (windows shouldn't inherit the menu enabled/disabled states of the
window they were opened from).
Depends on: 63026
Summary: menubar appears active for view source/info window, but...Menu options inactive in View Source Mode → Menu items don't work in View Source window
*** Bug 25287 has been marked as a duplicate of this bug. ***
Just marked 25287 as a dup though it's not STRICTLY a dup but the solution for 
view source just needs to be applied to hidden window. So this is a reminder to 
myself to fix hidden window while I'm here. ;-) Sorry for the spam.
David Karl reported, that he gets menus, if he loads Mozilla with chrome
parameter (with paramater file) and specifies an HTML document as "chrome",
which certainly doesn't have any menus. Could this be the same bug?
On second thought, pulling this forward to mozilla0.8.1
Target Milestone: mozilla0.9 → mozilla0.8.1
On third thought, this goes back to mozilla0.9. Since BenG still doesn't have
his mac out of customs, I think it would be a better use of my time to help him
fix bookmarks on mac.
Target Milestone: mozilla0.8.1 → mozilla0.9
Keywords: nsbeta1nsbeta1-, nsdogfood
Moving to mozilla0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
nav triage team:

Marking future.
Target Milestone: mozilla0.9.1 → Future
Keywords: nsdogfoodnsCatFood
nav triage: does not impact a sufficiently high percentage of the user base, to 
warrant a nscatfood+. 
Keywords: nsCatFoodnsCatFood-
sorry, but i'm renominating as catfood. maybe the majority of users don't view
source --but, this will affect anyone who does want to view and analyze the
source of a web page, such as web developers (of whom there are quite a few :).
Keywords: nsCatFood-nsCatFood
Blocks: 79518
Keywords: nsCatFoodnsCatFood-
Worksforme with build 2001062105, Mac OS 9.1. All the menu items that are there
work. Quite a few menus and menu items disappear unexpectedly when a source
window has focused, but I'll file those as separate bugs and note them in bug 63026.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Huh? When did we suddenly gain view source menus?
i added them for bug 63026
yep, v.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.