Search Bar + Google Search Engine leads to feature-poor Custom Google Search

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Kieran Elby, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080311 Ubuntu/9.10 (karmic) Firefox/3.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009080311 Ubuntu/9.10 (karmic) Firefox/3.0.13

Using the search bar + the default Google Search Engine leads to
a "Custom Google Search" results page, which is missing several
useful features from the normal Google Search page. This is bad.


Reproducible: Always

Steps to Reproduce:
1. Ensure the Search Engine is set to "Google"
2. Search for "Firefox" using the Search Bar.
Actual Results:  
The results page is a "Custom Google Search" page, which is missing
the following features:

* Cached and Similar links next to results
* Images, News, Groups, etc. tabs across the top


Expected Results:  
I'd expect to see broadly the same results page as if
I had performed my search on www.google.com.


This may be specific to the Ubuntu distribution of Firefox.

However, I have disabled the "Ubuntu Firefox Modifications"
addon, so I'm reporting the bug here since I was under the
impression that distributors could not modify Firefox without
changing the name?

This bug would be less of an issue if there was an easy workaround -
but I'm unable to figure out how to add a "Normal" Google Search Engine
to my search engines.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Comment 1

9 years ago
These are Ubuntu customizations. Please report deficiencies to them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.