Cannot install update to Firefox 3.5.2

RESOLVED DUPLICATE of bug 466778

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 466778
8 years ago
8 years ago

People

(Reporter: Robert Strauch, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

Version 3.5.1 of Firefox is in use. The update to 3.5.2 has been detected and downloaded automatically. When restarting Firefox, the update process is started but fails with the message that the update could not be performed.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 3.5.1 with auto-update enabled.
2. The update to 3.5.2 is downloaded. After pressing the confirmation button, Firefox restarts in order to install the update.
Actual Results:  
The update process starts but fails. Restarting Firefox starts 3.5.1.

Expected Results:  
Version 3.5.2 should have been started.
Component: Installer → Application Update
Product: Firefox → Toolkit
QA Contact: installer → application.update
Version: unspecified → 1.9.1 Branch
There should be a file named last-update.log in your updates directory which is typically located in your installation directory. Please attach it to this bug report
(Reporter)

Comment 2

8 years ago
Created attachment 392976 [details]
Error message during update process
Chances are there are files in use which makes this a duplicate of bug 466778.

As a workaround the installer should work if you are unable to get update to work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 466778
(Reporter)

Comment 4

8 years ago
When using the latest installer from mozilla.com, the update to 3.5.2 is applied successfully.
(Reporter)

Comment 5

8 years ago
Behavior occured again with the update from Firefox 3.5.3 to 3.5.4.

Comment 6

8 years ago
whenever i tried to update 3.5.5 to 3.5.6. it downloaded properly, but wen firefox restart for updating. it says "cannot install, any other instance of firefox is running." i closed all firefox related services, eeven restart laptop. but it did not work. At last, i set iNTERNET eXPLORER as my default browser, and again start firefox. it took update without any issue. :)
That sounds like you have another app that is keeping the default browser in use which will prevent applying an update
You need to log in before you can comment on or make changes to this bug.