window.open returns null

VERIFIED INVALID

Status

()

Core
XUL
P2
major
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

to reproduce, load mail, close all browser windows. Select multiple search 
engines in the search sidebar panel (right click on the tree to enable advanced 
search options that let you pick more than one search engine if you have not 
enabled this mode already), and run a search on anything. 

In the js console, you should see a message like this:

*** navWindow = null

the value is the value returned by a call to open() (or openDialog, both give 
the same results) attempting to load a new navigator window.

This value should be "A reference to a Window object, which may be a newly 
created or existing one, depending on the name argument." (JavaScript - The 
Definitive Guide, David Flanagan) Not sure how the applicable standard reads but 
it probably includes a similar description. Also, this used to work.

I haven't tried this in a html webpage but couldn't see why it'd be different 
there.

Comment 1

18 years ago
->danm, nominate for nsbeta3
Assignee: trudelle → danm
Keywords: nsbeta3

Comment 2

18 years ago
  There's nothing wrong with the return value from window.open -- a simple test 
case I just took the time to code up demonstrates that. A little poking around in 
search-panel.js reveals that the variable it's complaining about (navWindow) is 
likely being extracted from an element of the current window. If it were coming 
from a window.open call, wouldn't that be the function openNewNavigator(), which 
dumps its own debugging message and therefore isn't being called?
  Seems to me the JS is looking for a named element in the current window and not 
finding it. Back to the reporter for more analysis.
Assignee: danm → ben

Comment 3

18 years ago
nav triage team: we'll wait for more info before making a decision.

claudius: Ben, isn't this a dupe or very related to the old bug (recently 
reopened) that says search is not working from the mail sidebar panel?
Whiteboard: [NEED INFO]
this was a subtle error in my code exacerbated by a selection of similar 
sounding dump errors etc. Just looking to give you a reason to strangle me, dan 
;)

Claudius, this bug was opened during my attempts to fix that other search bug ;) 
Status: NEW → ASSIGNED

Comment 5

18 years ago
nav triage team:
nsbeta3+, P2, because needed to fix bug 32034 for shrimp (cc'ing bijals).

Ben, change the summary per Dan and your comments.
Blocks: 32034
Priority: P3 → P2
Whiteboard: [NEED INFO] → [nsbeta3+]
This bug is invalid. 
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 7

18 years ago
okay, marking VERIFIED to clean up. Do your earlier comments mean bug 32034 might
get fixed or what?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.