Closed Bug 509150 Opened 11 years ago Closed 11 years ago

Add-on update validator regular expression wrong for chrome.manifest

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 509427

People

(Reporter: Ken, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: 

The new add-on update validator's regular expression check for the chrome.manifest doesn't take into consideration the use of tabs after the strings "skin" and "style", it only considers spaces.  For formatting and ease of reading reasons it may be desirable to use tabs instead of space to separate strings on each line of the chrome.manifest.  The regular expression should take this into account to reduce the number of false warnings the add-on validator generates, thereby reducing frustration for everyone. 

Reproducible: Always
This is already fixed on preview but I don't have the bug number with me.  CCing RJ if he has it, otherwise I'll dupe it later.
This is already fixed by bug 509427
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509427
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.