Firefox 3.5 freezes when loading huge pages (The Older version works)

RESOLVED DUPLICATE of bug 477564

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 477564
9 years ago
9 years ago

People

(Reporter: Dominique, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

28.62 KB, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Opera/9.52 (Windows NT 6.0; U; fr-CA)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I acces my database (mySql) through a page we built. The page weight about 5.2 MB (17 000 items in the databse) Firefox loads the page but when it's partically complete, it just freezes and cliking on the screen actually turns the firefox window whiter... 

I have ran the Win Dbg find the Stack Trace attached

Reproducible: Always

Steps to Reproduce:
1.I open the page (it's password protected but a reagular http not https)
2.The page starts to load normally and I can see the that I'm partically finished
3.Then FF just hangs there waiting for data...
4. After that I clikck on the screen and it turns pale (white)
5. I have to go in the Control panel and stop FF (it shows no response) 


Expected Results:  
Page should load completely (BTW it works on my laptop and I use an older version of FF, Opera and IE don't have that bug either

about:buildconfig

Source

Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b8dbd5ab1647
Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --with-crashreporter-enable-percent=10
(Reporter)

Comment 1

9 years ago
Created attachment 393334 [details]
Stack trace using WinDbg

Comment 2

9 years ago
Does the page contains many checkboxes or other input? Then it is a dupe of bug 477654. The work around is to do:
about:config

and set privacy_level to 2.

Lucas

Comment 3

9 years ago
Sorry, bug 477564
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> Sorry, bug 477564


Yeah Lucas works!!! 

And yes the page does contain a checkbox per item... so that page load over 17 000 check box!!!!
(Reporter)

Comment 5

9 years ago
(In reply to comment #3)
> Sorry, bug 477564


Yeah Lucas works!!! 

And yes the page does contain a checkbox per item... so that page load over 17 000 check box!!!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 477564
You need to log in before you can comment on or make changes to this bug.