[PP][CRASH] Netcenter Yellow Pages crashes Seamonkey

VERIFIED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
major
VERIFIED WORKSFORME
20 years ago
19 years ago

People

(Reporter: Christine Hoffman, Assigned: Ramiro Estrugo)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Talkback not available on Linux, but gdb stack trace added, URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
Using 4/13 build on Win 95. Clicking on Bookmarks/Directories/NetCenter Yellow
Pages causes Apprunner to crash.

Details:

APPRUNNER caused an invalid page fault in
module RAPTORHTML.DLL at 0137:018d8e49.
Registers:
EAX=00000000 CS=0137 EIP=018d8e49 EFLGS=00010246
EBX=00000001 SS=013f ESP=00765084 EBP=00765090
ECX=00b68930 DS=013f ESI=00000000 FS=1957
EDX=32dd8a5f ES=013f EDI=00b68930 GS=0000
Bytes at CS:EIP:
8b 06 75 24 8d 4d 08 51 68 d0 b3 8f 01 56 ff 10
Stack dump:
00b68930 00000000 00000000 007650d0 018c0645 00b93bb4 ffffffff 007650b0 00973b50
00b68930 00000001 00450978 0045c740 00000000 00000000 0076513c

beppe: please check on Win 98
cpratt: please check on Win NT
petersen: please check on Mac
claudius: please check on Linux

Comment 1

20 years ago
crashes under nt 4 sp 4. talkback tracking id is DNO39SSM.

Comment 2

20 years ago
On the April 13th Mac M4 Build, the page loads in the window.

Updated

20 years ago
Severity: normal → major
Summary: Clicking on Bookmarks/Directories/NetCenter Yellow Pages casuse Apprunner to crash. Talkback ID #DN0220C0 → selecting bookmarks | dir... | netcenter yellow... crashes

Comment 3

20 years ago
chrisd reports: Talkback ID #DN0220C0

Updated

19 years ago
Hardware: PC → All
Summary: selecting bookmarks | dir... | netcenter yellow... crashes → [CRASH]selecting bookmarks | dir... | netcenter yellow... crashes

Comment 4

19 years ago
changing platform to all as it crashes the 1999041508 linux build as well.
(Reporter)

Comment 5

19 years ago
Using 4/20 build on Win 95, Win NT, Win 98, Mac8.5 and Linux:

Win 95: sporadic crashes (not every time)
Win NT: crash
Win 98: can't test - Apprunner crashes for another reason (bug written up)
Mac8.5: OK
Linux: page hangs - does not load, does not crash

Updated

19 years ago
Assignee: don → gagan
Component: Apprunner → Networking Library

Comment 6

19 years ago
Re-assigned to gagan@netscape.com, changed component to Networking Library, and
added URL.

Gagan, this appears to be yet another case of a re-direct crashing.  Don't you
already have a bug filed on this somewhere?  If so, I couldn't find it.

Comment 7

19 years ago
Deffered till Necko lands...

Updated

19 years ago
Component: Networking Library → JavaScript
QA Contact: 3853 → 4590
Summary: [CRASH]selecting bookmarks | dir... | netcenter yellow... crashes → [CRASH] Netcenter Yellow Pages crashes Seamonkey

Updated

19 years ago
Assignee: gagan → norris
Status: ASSIGNED → NEW

Comment 8

19 years ago
This bug is still taking place using the 4.30.99 builds on Win32 (NT 4), Mac OS,
and Linux.

This crash will take place irregardless of whether you select Yellow Pages from
the Bookmarks menu; e.g. if you go to www.netscape.com, and click Yellow Pages,
it will crash merely upon launching the page, with no redirects taking place.

Mike Judge believes that this is a JavaScript bug; per a quick chat with Gagan, I
am taking the liberty of reassigning it.

I'll also go ahead and decompose the page this afternoon to identify a minimized
reproduction case.

Comment 9

19 years ago
do you have a stack trace?

Comment 10

19 years ago
Yes. And you will within 3 minutes. ;)

Comment 11

19 years ago
See also Talkback ID D4Q04WMF.

Comment 12

19 years ago
Created attachment 100 [details]
Dr. Watson log excerpt (NT 4 machine).

Comment 13

19 years ago
Please note that this crash is preceeded by a 5-8 second pause, and may require
several page loads until the crash actually occurs. Talkback Tracking ID of
D4Q07JAA (on Mac) added.

* STACK CRAWL (Mac OS)

PowerPC unmapped memory exception at 0AC0B3B0
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  0BB20DC8
  03B09C80    PPC  0BB1FE18  main+006EC
  03B09AE0    PPC  0AD7D3D4  nsAppShellService::Run()+00018
  03B09AA0    PPC  0A8EF0C8  nsAppShell::Run()+00038
  03B09A20    PPC  0A8EF9FC  nsMacMessagePump::DoMessagePump()+0003C
  03B099D0    PPC  0A8EFC64  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00144
  03B09980    PPC  0AF0E12C  Repeater::DoRepeaters(const EventRecord&)+00030
  03B09940    PPC  0AF06470  TimerPeriodical::RepeatAction(const EventRecord&)+
00048
  03B098F0    PPC  0AF05FCC  TimerImpl::Fire()+00024
  03B098B0    PPC  0AE78B34  nsNetlibService::NetPollSocketsCallback(nsITimer*,
void*)+0001C
  03B09870    PPC  0AE539C8  NET_PollSockets+000A4
  03B09820    PPC  0AE4F284  NET_ProcessNet+003C4
  03B09490    PPC  0AE71400  net_ProcessHTTP+001EC
  03B09440    PPC  0AE44CE4  net_MemCacheComplete+000D0
  03B09400    PPC  0AE7C3A8  stub_complete(_NET_StreamClass*)+0008C
  03B09360    PPC  0A825C74  nsDocumentBindInfo::OnStopBinding(nsIURL*, unsigned
int, const u
nsigned short*)+00044
  03B09300    PPC  0AE8FB8C  nsUnicharStreamLoader::OnStopBinding(nsIURL*,
unsigned int, cons
t unsigned short*)+0001C
  03B092C0    PPC  0A9EAA1C  nsDoneLoadingScript(nsIUnicharStreamLoader*,
nsString&, void*, u
nsigned int)+00048
  03B09270    PPC  0A9EA67C  HTMLContentSink::ResumeParsing()+00024
  03B09230    PPC  0A924F6C  nsParser::EnableParser(int)+00064
  03B091D0    PPC  0A925A9C  nsParser::ResumeParse(nsIDTD*)+00104
  03B09180    PPC  0A924E10  nsParser::DidBuildModel(unsigned int)+0004C
  03B09140    PPC  0A91408C  CNavDTD::DidBuildModel(unsigned int, int, nsIParser*
, nsIContent
Sink*)+000CC
  03B09080    PPC  0A91874C  CNavDTD::CloseContainersTo(int, nsHTMLTag, int)+
000AC
  03B08F10    PPC  0A91859C  CNavDTD::CloseContainer(const nsIParserNode&,
nsHTMLTag, int)+00
108
  03B08EB0    PPC  0A917D18  CNavDTD::CloseBody(const nsIParserNode&)+00028
  03B08E60    PPC  0A9E77B8  HTMLContentSink::CloseBody(const nsIParserNode&)+
0005C
  03B08E10    PPC  0A9EDB90  nsHTMLDocument::ContentAppended(nsIContent*, int)+
000D8
  03B08DB0    PPC  0A9BCE70  nsDocument::ContentAppended(nsIContent*, int)+0004C
  03B08D50    PPC  0A9CDBA4  PresShell::ContentAppended(nsIDocument*, nsIContent*
, int)+00060
  03B08D00    PPC  0A9CA9BC  PresShell::ExitReflowLock()+0002C
  03B08CC0    PPC  0A9CC464  PresShell::ProcessReflowCommands()+000D4
  03B08C40    PPC  0AA46540  nsHTMLReflowCommand::Dispatch(nsIPresContext&,
nsHTMLReflowMetri
cs&, const nsSize&, nsIRenderingContext&)+000B8
  03B08B40    PPC  0ABE28A4  ViewportFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+00278
  03B089D0    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B08970    PPC  0AA4773C  nsScrollFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+0052C
  03B08650    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B085F0    PPC  0AA54AA8  RootFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const n
sHTMLReflowState&, unsigned int&)+00228
  03B08440    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B083E0    PPC  0ABCA8F8  nsAreaFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+000C8
  03B08360    PPC  0AB600BC  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001F4
  03B077A0    PPC  0AB60DEC  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00064
  03B07720    PPC  0AB61224  nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int*)+
000A0
  03B076D0    PPC  0AB620B0  nsBlockFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
int*)+0015C
  03B07540    PPC  0ABBECD0  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 int, int, nsMargin&, unsigned int&)+00268
  03B07420    PPC  0AB600BC  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001F4
  03B06860    PPC  0AB60DEC  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00064
  03B067E0    PPC  0AB61224  nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int*)+
000A0
  03B06790    PPC  0AB620B0  nsBlockFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
int*)+0015C
  03B06600    PPC  0ABBECD0  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 int, int, nsMargin&, unsigned int&)+00268
  03B064E0    PPC  0AB600BC  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001F4
  03B05920    PPC  0AB60DEC  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00064
  03B058A0    PPC  0AB61224  nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int*)+
000A0
  03B05850    PPC  0AB620B0  nsBlockFrame::ReflowBlockFrame(nsBlockReflowState&,
nsLineBox*,
int*)+0015C
  03B056C0    PPC  0ABBECD0  nsBlockReflowContext::ReflowBlock(nsIFrame*, const
nsRect&, int,
 int, int, nsMargin&, unsigned int&)+00268
  03B055A0    PPC  0AA3D39C  nsTableOuterFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&,
 const nsHTMLReflowState&, unsigned int&)+00278
  03B051F0    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B05190    PPC  0AA34598  nsTableFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001A4
  03B05080    PPC  0AA34AA4  nsTableFrame::ResizeReflowPass1(nsIPresContext&,
nsHTMLReflowMet
rics&, const nsHTMLReflowState&, unsigned int&, nsTableRowGroupFrame*,
nsReflowReason, int)+0
0178
  03B04DC0    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B04D60    PPC  0AA42F28  nsTableRowGroupFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetric
s&, const nsHTMLReflowState&, unsigned int&)+00170
  03B04C70    PPC  0AA41C20
nsTableRowGroupFrame::ReflowMappedChildren(nsIPresContext&, nsHT
MLReflowMetrics&, RowGroupReflowState&, unsigned int&, nsTableRowFrame*,
nsReflowReason, int)
+00140
  03B04AF0    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B04A90    PPC  0AA4088C  nsTableRowFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, c
onst nsHTMLReflowState&, unsigned int&)+000FC
  03B04940    PPC  0AA3F498  nsTableRowFrame::InitialReflow(nsIPresContext&,
nsHTMLReflowMetr
ics&, RowReflowState&, unsigned int&, nsTableCellFrame*, int)+0021C
  03B046C0    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B04660    PPC  0AA2B660  nsTableCellFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&,
const nsHTMLReflowState&, unsigned int&)+0032C
  03B04440    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B043E0    PPC  0ABCA8F8  nsAreaFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, const
 nsHTMLReflowState&, unsigned int&)+000C8
  03B04360    PPC  0AB600BC  nsBlockFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, cons
t nsHTMLReflowState&, unsigned int&)+001F4
  03B037A0    PPC  0AB60DEC  nsBlockFrame::ReflowDirtyLines(nsBlockReflowState&)+
00064
  03B03720    PPC  0AB61240  nsBlockFrame::ReflowLine(nsBlockReflowState&,
nsLineBox*, int*)+
000BC
  03B036D0    PPC  0AB62634  nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&
, nsLineBox*
, int*)+00134
  03B03640    PPC  0AB62884  nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&,
nsLineBox*,
 nsIFrame*, unsigned char*)+00040
  03B035D0    PPC  0AB68DF0  nsLineLayout::ReflowFrame(nsIFrame*, nsIFrame**,
unsigned int&)+
00318
  03B03460    PPC  0AB5C534  nsInlineFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetrics&, con
st nsHTMLReflowState&, unsigned int&)+001B8
  03B033F0    PPC  0AB5C880  nsInlineFrame::ReflowInlineFrames(nsIPresContext*,
const nsHTMLR
eflowState&, nsInlineFrame::InlineReflowState&, nsHTMLReflowMetrics&, unsigned
int&)+000AC
  03B03360    PPC  0AB5CCE4  nsInlineFrame::ReflowInlineFrame(nsIPresContext*,
const nsHTMLRe
flowState&, nsInlineFrame::InlineReflowState&, nsIFrame*, unsigned int&)+00080
  03B032F0    PPC  0AB68DF0  nsLineLayout::ReflowFrame(nsIFrame*, nsIFrame**,
unsigned int&)+
00318
  03B03180    PPC  0AB52240  nsHTMLFrameOuterFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetri
cs&, const nsHTMLReflowState&, unsigned int&)+001E8
  03B03010    PPC  0A9B796C  nsContainerFrame::ReflowChild(nsIFrame*,
nsIPresContext&, nsHTML
ReflowMetrics&, const nsHTMLReflowState&, unsigned int&)+00088
  03B02FB0    PPC  0AB53F34  nsHTMLFrameInnerFrame::Reflow(nsIPresContext&,
nsHTMLReflowMetri
cs&, const nsHTMLReflowState&, unsigned int&)+0011C
  03B02EB0    PPC  0A82EFEC  nsWebShell::LoadURL(const unsigned short*,
nsIPostData*, int, ns
URLReloadType, unsigned int)+00058
  03B02E60    PPC  0A82FDD4  nsWebShell::LoadURL(const unsigned short*, const
char*, nsIPostD
ata*, int, nsURLReloadType, unsigned int)+00398
  03B02D10    PPC  0A82F334  nsWebShell::DoLoadURL(const nsString&, const char*,
nsIPostData*
, nsURLReloadType, unsigned int)+002DC
  03B02C30    PPC  0A822F98  nsDocLoaderImpl::LoadDocument(const nsString&, const
char*, nsIC
ontentViewerContainer*, nsIPostData*, nsISupports*, nsIStreamObserver*,
nsURLReloadType, unsi
gned int)+00190
  03B02BC0    PPC  0A825350  nsDocumentBindInfo::Bind(const nsString&,
nsIPostData*, nsIStrea
mListener*)+00140
  03B02B70    PPC  0A824080  nsDocLoaderImpl::FireOnStartDocumentLoad(nsIURL*,
const char*)+0
007C
  03B02B20    PPC  0A824058  nsDocLoaderImpl::FireOnStartDocumentLoad(nsIURL*,
const char*)+0
0054
  03B02AD0    PPC  0A831B00  nsWebShell::OnStartDocumentLoad(nsIDocumentLoader*,
nsIURL*, con
st char*)+000BC
  03B02A40    PPC  0AD090B4  GlobalWindowImpl::HandleDOMEvent(nsIPresContext&,
nsEvent*, nsID
OMEvent**, unsigned int, nsEventStatus&)+00048
  03B029F0    PPC  0AA4E070  nsEventListenerManager::HandleEvent(nsIPresContext&,
nsEvent*, n
sIDOMEvent**, unsigned int, nsEventStatus&)+00C94
  03B02900    PPC  0AD39C98  nsJSEventListener::HandleEvent(nsIDOMEvent*)+00190
  03B02860    PPC  0ADE338C  JS_CallFunctionValue+00014
  03B02820    PPC  0ADFBB9C  js_CallFunctionValue+000B8
  03B02770    PPC  0ADFB99C  js_Invoke+0057C
  03B02690    PPC  0AE019F4  js_Interpret+057BC
  03B02450    PPC  0ADFB99C  js_Invoke+0057C
  03B02370    PPC  0AE019F4  js_Interpret+057BC
  03B02130    PPC  0ADFB99C  js_Invoke+0057C
  03B02050    PPC  0AE011B8  js_Interpret+04F80
  03B01E10    PPC  0AE09FF0  js_GetProperty+00224
  03B01D90    PPC  0AD2D708  GetHTMLSelectElementProperty(JSContext*, JSObject*,
long, long*)
+000EC
  03B01C20    PPC  0AB09E2C  nsHTMLSelectElement::GetSelectedIndex(int*)+00060

Comment 14

19 years ago
When I copy the Yellow Pages web page to a personal HTTP server, the page no
longer results in a crash. So, I can't really investigate this usefully.

Per chat with Paulmac, I note that there's a readCookie() at the top of the page,
and it might behave differently enough to result in a crash on the
www.netscape.com domain than on the www.prometheus-music.com (home) domain, which
doesn't supply cookies.

But that's a wild guess.

Comment 15

19 years ago
*** Bug 5324 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: 4590 → 4015

Comment 16

19 years ago
so way not my problem.

Updated

19 years ago
Assignee: norris → vidur
Component: JavaScript → DOM Level 0

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 17

19 years ago
Fix checked in on 5/17/1999. The onunload message for the contained IFRAME was
bubbling incorrectly.

Updated

19 years ago
Status: RESOLVED → REOPENED
OS: Windows 95 → Linux

Comment 18

19 years ago
Verified bug fix on Win 95 and Win NT. However, the described failure is still
happening on Linux on the 1999-06-02-09 build. Updated OS and reopening bug...

Comment 19

19 years ago
Putting on [PP] radar
Resolution: FIXED → ---
Summary: [CRASH] Netcenter Yellow Pages crashes Seamonkey → [PP][CRASH] Netcenter Yellow Pages crashes Seamonkey

Updated

19 years ago
Assignee: vidur → ramiro
Status: REOPENED → NEW

Comment 20

19 years ago
Ramiro, could you help with this seemingly Linux-only bug? Tom Pixley or I can
consult since we know the XP code involved. Thanks.

Comment 21

19 years ago
I can load this page fine on both the viewer and apprunner on linux with a build
from june/28/1999.

Comment 22

19 years ago
The build from 6/28 still causes a Segmentation fault on my machine, after
displaying several instances of the error msg:

Gtk-CRITICAL **: file gtkcontainer.c: line 717 (gtk_container_remove): assertion
'widget->parent == GTK_WIDGET (container)' failed

Stack trace to be attached soon...

Comment 23

19 years ago
Program received signal SIGSEGV, Segmentation fault.
0x401101fa in net_finish_setup_http_stream ()
(gdb) bt
#0  0x401101fa in net_finish_setup_http_stream ()
#1  0x4010fba6 in net_setup_http_stream ()
#2  0x40110aa2 in net_ProcessHTTP ()
#3  0x401b6f93 in NET_ProcessNet ()
#4  0x401bc62b in NET_PollSockets ()
#5  0x401d510d in nsNetlibService::NetPollSocketsCallback ()
#6  0x400f61ea in TimerImpl::FireTimeout ()
#7  0x400f651c in nsTimerExpired ()
#8  0x80e77d3 in g_timeout_dispatch (source_data=0x85a9200,
current_time=0xbffff6fc, user_data=0x85d67b0) at gmain.c:1147
#9  0x80e6d58 in g_main_dispatch (current_time=0xbffff6fc) at gmain.c:647
#10 0x80e71d3 in g_main_iterate (block=1, dispatch=1) at gmain.c:854
#11 0x80e72ed in g_main_run (loop=0x81b3a70) at gmain.c:912
#12 0x8085213 in gtk_main () at gtkmain.c:475
#13 0x400b1e7f in nsAppShell::Run ()
#14 0x4001aa2a in nsAppShellService::Run ()
#15 0x80520c7 in main ()

Updated

19 years ago
Whiteboard: Talkback not available on Linux, but gdb stack trace added
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 24

19 years ago
tried it on linux just now, seems to work fine.  probably necko fixed it.

marking worksforme.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 25

19 years ago
Verified on 1999-08-30-01-M10 build.
You need to log in before you can comment on or make changes to this bug.