mochitest-plain: intermittent 'test_media_selection.html | Test timed out.'

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
9 years ago
4 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249731779.1249733756.30918.gz
Linux mozilla-central test mochitests on 2009/08/08 04:42:59

27745 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_media_selection.html | Test timed out.
(Reporter)

Updated

9 years ago
Blocks: 438871
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251235316.1251238069.10450.gz
Linux mozilla-central test mochitests on 2009/08/25 14:21:56
I think this test is doing something weird that confuses the harness:
29440 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | test 37 readyState should be HAVE_NOTHING when load fails.
29441 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | error handler should run once only!
29442 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | test 38 readyState should be HAVE_NOTHING when load fails.
29443 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_media_selection.html | Test timed out.
29445 INFO Running /tests/content/media/test/test_mixed_principals.html...
29446 INFO TEST-PASS | /tests/content/media/test/test_mixed_principals.html | test 39 readyState 4 expected >= 1
29447 INFO TEST-PASS | /tests/content/media/test/test_mixed_principals.html | test 39
29448 INFO TEST-PASS | /tests/content/media/test/test_mixed_principals.html | test 39 networkState = 3 expected >= 1
file=[xpconnect wrapped nsILocalFile]
file=[xpconnect wrapped nsILocalFile]
29449 INFO TEST-PASS | /tests/content/media/test/test_mixed_principals.html | Threw exception in toDataURL for v2

It looks like the harness thinks the test timed out, and moves on to the next test, but the previous test is still executing (although its tests are being accounted to the next test!).
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251328519.1251336051.20112.gz
Linux mozilla-central unit test on 2009/08/26 16:15:19

Comment 7

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251636291.1251644993.23307.gz
Linux mozilla-central unit test on 2009/08/30 05:44:51

Comment 8

9 years ago
(In reply to comment #7)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251636291.1251644993.23307.gz
> Linux mozilla-central unit test on 2009/08/30 05:44:51

Sorry, commented too soon.  This failure has a different message:

29266 INFO Running /tests/content/media/test/test_media_selection.html...
29267 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_media_selection.html | [SimpleTest/SimpleTest.js, window.onerror] An error occurred - Script error.
29268 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | Test bug506094.ogv 0 - corrent number of events received
29269 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | Test bug506094.ogv 0 - events received in order
29270 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | Test bug506094.ogv 0 - corrent number of events received
29271 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | Test bug506094.ogv 0 - events received in order
29272 INFO TEST-PASS | /tests/content/media/test/test_media_selection.html | Test bug506094.ogv 0 - corrent number of events received
...

Comment 9

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251649975.1251657912.10895.gz
Linux mozilla-central unit test on 2009/08/30 09:32:55
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251847131.1251855592.10372.gz
Linux mozilla-central unit test on 2009/09/01 16:18:51
Linux mozilla-central test mochitests on 2009/09/01 19:45:24
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251859524.1251861874.13258.gz

29441 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_media_selection.html | Test timed out.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251971604.1251977423.24194.gz
Linux mozilla-central unit test on 2009/09/03 02:53:24
Linux mozilla-central test mochitests  [testfailed] Started 14:13, finished 15:00
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1252617235.1252619957.6666.gz&fulltext=1
Linux mozilla-central test mochitests on 2009/09/16 07:45:01
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1253112301.1253114902.7732.gz
(Reporter)

Comment 21

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253864500.1253867033.16082.gz
Linux mozilla-1.9.2 test mochitests on 2009/09/25 00:41:40
(Reporter)

Comment 22

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253882376.1253884511.24062.gz
Linux mozilla-1.9.2 test mochitests on 2009/09/25 05:39:36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253966229.1253968398.23424.gz
Linux mozilla-1.9.2 test mochitests on 2009/09/26 04:57:09
roc - this is pretty ruinous on Linux, and hg log says that you're the one touching it:

http://hg.mozilla.org/mozilla-central/log/2c6aeb49c93c/content/media/test/test_media_selection.html

any chance you can take a look at this, or get someone else to?

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1254220417.1254223378.20330.gz&fulltext=1
Linux mozilla-1.9.2 test mochitests on 2009/09/29 03:33:37

Comment 25

9 years ago
Roc comments in bug 518659 comment 6 that he thinks he knows what the problem is and the patch to that bug should fix it. I'm reviewing it. Hopefully will be fixed rsn.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
This hasn't failed for several months, so I'm marking this resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Reporter)

Comment 34

8 years ago
(In reply to comment #33)
> This hasn't failed for several months, so I'm marking this resolved fixed.

NB: When the exact fix is unknown, you should use WorksForMe.
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 35

8 years ago
(In reply to comment #25)
> Roc comments in bug 518659 comment 6 that he thinks he knows what the problem
> is and the patch to that bug should fix it. I'm reviewing it. Hopefully will be
> fixed rsn.

PS: Or, if that bug did fix this one, then it should be marked as blocking...
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.