Closed Bug 509202 Opened 13 years ago Closed 12 years ago

Addressbar displays ssl identy in punycode with browser.identity.ssl_domain_display=1

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: klebom, Assigned: dwitte)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

When browser.identity.ssl_domain_display = 1 firefox displays IDN Domains (Internationalized Domain Names) in punycode, however when the setting is 2 the same name is properly displayed

An example:

browser.identity.ssl_domain_display = 1:
xn--musikkren-kamraterna-1zb.se  https://www.musikkåren-kamraterna.se/

browser.identity.ssl_domain_display = 2:
www.musikkåren-kamraterna.se  https://www.musikkåren-kamraterna.se/


Expected result:

The identity should always be displayed properly for IDNs in trusted toplevel IDNs.


Reproducible: Always
Since this bug report have not gotten any attention for nearly a month I nominated it as a blocker just to be seen...
blocking2.0: --- → ?
Status: UNCONFIRMED → NEW
Component: General → Location Bar and Autocomplete
Ever confirmed: true
QA Contact: general → location.bar
More information: we ship with browser.identity.ssl_domain_display set to 1 by default.
We should fix this, yes. Especially if we end up getting rid of the URL in favour of showing the identity indicator (a proposal at this point, don't panic!)
blocking2.0: ? → betaN+
Yoink.
Assignee: nobody → dwitte
Attached patch patch (obsolete) — Splinter Review
Piece of cake.
Attachment #469641 - Flags: review?(gavin.sharp)
Attached patch patch v2Splinter Review
Now with test.
Attachment #469641 - Attachment is obsolete: true
Attachment #469669 - Flags: review?(gavin.sharp)
Attachment #469641 - Flags: review?(gavin.sharp)
OS: Windows XP → All
Hardware: x86 → All
Comment on attachment 469669 [details] [diff] [review]
patch v2

>diff --git a/browser/base/content/browser.js b/browser/base/content/browser.js

>   getEffectiveHost : function() {

>+      var baseDomain =
>+        this._eTLDService.getBaseDomainFromHost(this._lastLocation.hostname);
>+      var isASCII = {};
>+      return this._IDNService.convertToDisplayIDN(baseDomain, isASCII);

Use let, and omit isASCII and just pass {} directly?
Attachment #469669 - Flags: review?(gavin.sharp) → review+
http://hg.mozilla.org/mozilla-central/rev/a64bb4bf114d
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.