Illegal instruction with Flash 10.0 r32 64-bit

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: evans.jahja, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090807 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090807 Minefield/3.6a1pre

Some flash games (some videos too) make FF crash when loading. If I launch Firefox from terminal, when it crash it says "Illegal instruction" (nothing else).

Reproducible: Always

Steps to Reproduce:
Example, not the only one
1. http://www.newgrounds.com/portal/view/505914
2. http://www.newgrounds.com/portal/view/506363
3. http://www.newgrounds.com/portal/view/506141
Actual Results:  
BOOM It crash landed!!!

Expected Results:  
Errr ability to play the game?
(Reporter)

Comment 1

9 years ago
By the way, it's Minefield (64 bit browser with 64 flash), is it still Firefox?

Updated

9 years ago
Version: unspecified → Trunk

Comment 2

9 years ago
No crash for me on 32-bit Linux, so probably 64-bit specific.

To answer your question, the product to put a Minefield bug under is Firefox with Trunk as the version. Seeing as it's not a Firefox bug, but rather Flash, it goes under core:plugins.

Though, if this is a Flash bug it's not a Mozilla bug. CCing Macromedia to see if they want to look into this here.
Severity: major → critical
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: Illegal instruction with flash 10.0 r32 → Illegal instruction with Flash 10.0 r32 64-bit
(Reporter)

Comment 3

9 years ago
well, it appears to be minefield's problem, since the bug is no longer occur with Namoroka (3.6a2pre) (and same flash version)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Resolution: FIXED → WORKSFORME

Comment 4

9 years ago
FWIW, we recently added a plugins product to make it easier for everyone to handle plugin related problems.

However if upgrading firefox made your problem "go away", and running the older version of firefox causes the problem to recur (please check?) then the problem really does belong here instead of in plugins:flash (adobe). Please check (and indicate your version of flash).

OTOH, it's possible the bug was caused by bad site content and a buggy flash player, in which case it's possible that the site worked around the flash bug. So if you can't reproduce with that same flash player and firefox 3.6a1pre 20090807 then this bug probably belongs in Plugins:Flash.
You need to log in before you can comment on or make changes to this bug.