deleted messages are not erased from disk

VERIFIED INVALID

Status

VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: francois.rotzinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009021111 Minefield/3.0.6
Build Identifier: 

When mail arrives (in "Inbox"), which is moved subsequently into another folder (e. g. test), the message does no longer appear in "Inbox", but it is not erased from the disk (this can be verified via e. g. "vi Inbox").
If, in a second step, this message is deleted from the "test" folder, it is not shown in this folder anymore, but again, it is not erased (as verified via "vi test"). Emptying of the Trash does not remove the message from "Inbox" or "test"; it continues to occupy disk space. This way, the occupation of disk space increases continuously, although the treated messages were deleted.

Reproducible: Always

Steps to Reproduce:
1. Get a message into your "Inbox" folder.
2. Verify the size of "Inbox" (e. g. "du Inbox").
3. Move this message to another folder (e. g. "test").
4. Verify the size of "Inbox" (it is unchanged).
5. Verify the size of "test".
6. Delete the message in "test".
7. Verify the size of "test" (it is unchanged).
8. Empty Trash.
9. Verify the size of "Inbox" and "test" (unchanged).
10. Using vi or any other editor, you can verify that the message is still in "Inbox" and in "test", although it is not shown by Thunderbird.


Expected Results:  
The disk space increases with the number and size of received mails.

The software should have removed this mail from the "Inbox" and the "test" files.
That is by design, you need to do a compact folder (File/compact folders or compact folder from the context menu of a folder)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.