Firefox in offline mode when laptop wakes from sleep

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: bugKb, Unassigned)

Tracking

1.9.1 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-05-11])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

When my laptop wakes up from sleep, Firefox always reports itself as being offline.

Reproducible: Always

Steps to Reproduce:
1.Shutdown laptop to sleep mode
2.Start laptop

Actual Results:  
You will see Firefox in work offline mode.

Expected Results:  
Firefox should not be in offline mode as it was not before laptop was put to sleep mode.

Firefox should have continued where it left off.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Updated

9 years ago
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 3.5 Branch → 1.9.1 Branch

Comment 1

8 years ago
Note that the work offline menu item is not checked, and toggling it does nothing; the only way to restore network access is to shut down Firefox.

Comment 2

8 years ago
Ignore the above comment. I'm having a similar problem on OS X in the following trunk build: 

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101129 Firefox/4.0b8pre

Updated

7 years ago
Duplicate of this bug: 498831

Comment 4

7 years ago
kb, do you still see this problem when using FF 4 or 3.6?
Whiteboard: [closeme 2011-05-11]

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 5

6 years ago
I haven't seen this in years -- I can't remember when it was fixed, but it was, and definitively. I'm cool with marking this as complete.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.