If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Minor test suite tweaks for themes (from blog)

RESOLVED FIXED in 5.0.9

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: clouserw, Assigned: rjwalsh)

Tracking

unspecified
5.0.9

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Comment from the blog:

-------------------------------------------------------
Note that the verification suite generates lots of false hits on themes:
Things like:
chrome/littlefox.jar/browser/feedview.css (39) : Matched Pattern: “/-moz-binding:(?!\s*url\s*\(\s*["']?chrome:\/\/.*\/content\/)/”
and:
chrome.manifest (1) : Matched Pattern: “/^(?!(#|skin |style ))/”
are actually OK for themes.

So, the suite needs to be more tuned to Themes as well.

-------------------------------------------------------
We need to verify these tests and clarify if themes are different than extensions and adjust the tests accordingly.
(Assignee)

Comment 1

8 years ago
Created attachment 393585 [details] [diff] [review]
Fix

Changes the remote javascript test to allow resources to be pulled from content or skin, as opposed to just content.
Changes the chrome manifest check to use the regex whitespace identifier as opposed to a space.  This will match both tabs and spaces.
Attachment #393585 - Flags: review?(clouserw)
(Reporter)

Updated

8 years ago
Attachment #393585 - Flags: review?(clouserw) → review+
(Assignee)

Comment 2

8 years ago
Fixed in r48920
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 509150
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.