bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox unable to restart opened tabs after re-launching

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: Harry Kümel, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

Since the latest upgrade to Firefox/3.5.2 (.NET CLR 3.5.30729) and two upgrades before, the browser seems unable or unwilling to find last opened tabs/sites on re-launching even if they have been duly saved on exit. Instead one gets a screen with a "oops" comment + a list of the last opened tabs/sites, which says (in my case in Dutch) that "it is awfully embarrassing" that the program can't find its bearing. After clicking the renew button, everything loads normally. Let me insist: this never happened before to my recollection - only since the latest upgrades.

What gives?

All the best,

Harry

Reproducible: Always

Steps to Reproduce:
1. Close browser and save the opened tabs
2. Re-launch browser
3.
Actual Results:  
See "details". Got a "oops" screen instead of the latest opened tabs.

Expected Results:  
That all saved tabs would open normally, instead after a "oops" screen, and a refresh.

Updated

9 years ago
Duplicate of this bug: 509515

Comment 2

9 years ago
Sessionstore aka Session Restore is affected. Can't verify this error. Please post the values of the browser.sessionstore.* preferences.
Version: unspecified → 3.5 Branch
(Reporter)

Comment 3

9 years ago
Created attachment 393740 [details]
Screenshot of "oops" window
(Reporter)

Comment 4

9 years ago
Reply to comment #1

Bug 509815 is not a duplicate of the bug I reported. 

If the result therein is similar ("Firefox does not restore session"), the cause is different. Indeed, as reported bug 509815 occurs after an accidental shut-down of the computer due to a dead or exhausted battery. On the other hand, the present one occurs after each normal shut-down, followed by an as normal boot-up (whether immediately or after several hours). 

Allow me to expand however on my first report: in my case you do not even need to save a session because the bug occurs also when Firefox tries to restore the start page (in my case Google) as a single tab, which had of course not been saved as a session. Could it simply be that some "option" has been added or removed unintentionally?
Severity: normal → major

Updated

9 years ago
Duplicate of this bug: 513525

Comment 6

9 years ago
This happens because the application wasn't closed properly (shut down, out of battery, ...). If a crash happens twice in a certain period, then this screen is shown, because Firefox is assuming that the crash is caused by one of the tabs. It's *asking* you to remove that tab (not to restore it), so that the crash won't happen again.
(Reporter)

Comment 7

9 years ago
Reply to last message:
Wish the problem were a mere unorthodox exit. But no. The incident happens when exiting absolutely normally from Windows XP SP3, without any mishap.

Thank you anyway for the reaction.

HK
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
(Reporter)

Comment 9

8 years ago
I close this thread: since the problem kept occurring with FF whatever I tried, I changed over to Chrome.

Thanks anyway for your help.

HK
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.