Closed Bug 509477 Opened 12 years ago Closed 12 years ago

Inline elements with white-space:nowrap seem to behave incorrectly inside the container with display:table

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 484448

People

(Reporter: selenit, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

When two inline-level elements with white-space:nowrap are separated just with a white-space character(s) and appear inside the element with display:table (this is often used to gain new formatting context for floats etc.), these white-space characters are ignored and the elements are displayed in one line without spaces (as if they turned into table cells).

Reproducible: Always

Steps to Reproduce:
1. Open the testcase page with Firefox
2. Look at the rendering of the rainbow-colored inline elements and red-bordered fixed width container.
Actual Results:  
The rainbow-colored elements are rendered in one line without any spaces, and the container exceeds the given width value.

Expected Results:  
I expect that the elements should be space-separated (like regular words) and wrap to the next line (as a whole) to fit the given container width.

MSIE8, Opera 9.63, and Opera 10.00b display the testcase page in three lines. Safari 4/Win and Chrome 2 behave the same way as Firefox, but I cant't find the reason for this behavior in CSS2.1 spec.
On trunk, latest Minefield builds, the testcase displays on 3 lines,just as Opera 10b does.

The behaviour changed between the 20090414 and 20090415 builds
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=398bc50386b7&tochange=94f13c5d8aec

I think this was fixed by bug 484448.

Boris, dupe to bug 484448 ?
Component: General → Layout
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → layout
Hardware: x86 → All
Version: unspecified → Trunk
Yes, exactly.  Good catch!
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484448
You need to log in before you can comment on or make changes to this bug.