MailandNews IMAP: Can't purge IMAP messages

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
19 years ago
10 years ago

People

(Reporter: pratik.solanki, Assigned: Bienvenu)

Tracking

({imap-interop})

Trunk
x86
Linux
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(8 attachments)

(Reporter)

Description

19 years ago
I can't seem to purge IMAP messages. I delete teh messages and it shows up as
deleted but when I press 'Compact Folder', they don't seem to be deleted. Infact
the messages marked 'deleted' get marked normal again.

Details
Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i686; en-US; m18) Gecko/20000830

Comment 1

19 years ago
Can you attach an IMAP log file?
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html
QA Contact: lchiang → huang

Comment 2

19 years ago
By using today's Linux build, I am not able to reproduce this problem on an 
IMAP migrated profile, I can delete the IMAP messages and compact the folder as 
well. After I relaunch again, messages have been removed. I couldn't setup the 
delete mode for new profile since ther was bug 50685.
(Reporter)

Comment 3

19 years ago
Created attachment 13870 [details]
output file ("./mozilla >output.log")
(Reporter)

Comment 4

19 years ago
I was supposed to post this message along with teh attachment but for some
reason only the attachment got posted. Sorry.

----
I got the latest build (2000083121) and the problem persists. I tried creating
an IMAP log file but was unable to do so for some reason. I have the following
two variables defined in my .bashrc

NSPR_LOG_FILE=/home/psolanki/package/logs/imap.log
NSPR_LOG_MODULES=IMAP:5

Am I missing something? The file is not getting created.

So I did a "./mozilla > output.log" and I am attaching the file along. My imap
server is mailandnews.com (www.mailandnews.com). The messages get purged in
Netscape 4.7.

Pratik.

Comment 5

19 years ago
Above setup is wrong, can you setup as follwoing again in your ~/.bashrc file?
setenv NSPR_LOG_MODULES IMAP:5 
setenv NSPR_LOG_FILE /home/psolanki/package/logs/imap.log
(Reporter)

Comment 6

19 years ago
No, setenv doesn't work under bash. I did 'export NSPR.....' and it worked.

Attaching the log file in next post.
(Reporter)

Comment 7

19 years ago
Created attachment 13883 [details]
Here is the IMAP log file. Sequence of events. - Opened mailbox, opened one message, deleted the message, clicked 'Compact Folder', Quit.

Comment 8

19 years ago
I still cannot reproduce this problem by following the same steps as Pratik on
today's Linux build 09-01-08-M18 commercial build.
After setup delete mode from 4.x, migrated to 6.0  -- delete the message from
Inbox, compact folder for Inbox and relaunch again, the message already been
removed. I attach IMAP log as following.

Comment 9

19 years ago
Created attachment 13885 [details]
Attach the IMAP log with same scenario but successfully purge IMAP messages

Comment 10

19 years ago
Change Component to Networking-IMAP, reassign to mscott, Ccing bienvenu.
Assignee: putterman → mscott
Component: Mail Window Front End → Networking - IMAP
(Reporter)

Comment 11

19 years ago
True, I can't seem to reproduce it myself with another IMAP server. I guess its
the Mozilla/mailandnews.com combination thats screwing up something somewhere.
Try getting an account on mailandnews.com (free email + free IMAP) and see if it
works for you. Since mailandnews.com works fine with Netscape 4.7 (and Outlook
for that matter), I think you should investigate a little more deeper into the
cause for this peculiar behaviour.

Comment 12

19 years ago
OK. I think that we need to investigate more to know whether this is migration 
problem , IMAP delete mode purge messages problem or other....

Since without bug 50685 fix, after I migrated my "mailandnews account" profile 
with delete mode setup from 4.x to 6.0, I tried for deleting the messages, 
There are problems:
1) The "x" sign not display at all on the thread pane (not sure it migrated to 
the right delete mode or not on 6.0)
2) no way to check on the Account setting to verify that since blocked by bug 
50685
3) no way to verify on the new profile to narrow down whether this problem 
is on IMAP delete mode or not? (blocked by bug 50685)
4) Actually, don't need to exit the app, after you switch to other folder, the 
deleted messages display back on thread pane.....
5) I will keep an eye on it after we have fix on 50685 and narrow down this 
problem afterward.

Comment 13

19 years ago
Created attachment 13909 [details]
Attache the screen shot for the mailandnews mail account

Comment 14

19 years ago
mailandnews mail account with addtional "Deleted" and "Outbox" folders which is
interesting for us to investigate more......
Adding MailandNews IMAP on the summary and keywords "interop" since problem is
only occurring on this specific IMAP server.....
Keywords: interop
Summary: Can't purge IMAP messages → MailandNews IMAP: Can't purge IMAP messages

Comment 15

19 years ago
Confirm/change bug status to new since I can reproduce this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 16

19 years ago
Here's another IMAP server that doesn't seem to be working with Mozilla (build
2000090421) on linux. www.myrealbox.com. And the funny thing is that the server
sent back an error message. Here's what the dialog box says

'The current command did not succeed. The mail server responded: Read-only
Mailbox! Your browser is not RFC compliant since it ignores the mailbox state'

Does this help in any way?
(Reporter)

Comment 17

19 years ago
Funny. I can't seem to reproduce the error message anymore so I can't send you
guys the log file. and it seems to be sort of working now. Forget my previous
comment. If it happens again and I get a log file, I'll post again.

Comment 18

19 years ago
By using today's Linux 09-05-08-M18 commercial build:
Yes. I think that this is delete mode "mark as delete" problem on this specific 
IMAP account since I can reproduce the original sceanrio on the NEW profile and 
actually after you delete the messages and just selecting the other folder and 
back to Inbox, the "x" sign will disappear beside the deleted messages at this 
time....
(Reporter)

Comment 19

19 years ago
Created attachment 14504 [details]
I finally got the error message *Read only mailbox. Browser not RFC compliant* again. Here's the gzipped file.
(Reporter)

Comment 20

18 years ago
I thought this bug had got fixed because for some time now I was able to delete
messages successfully. However, for the last week or so, I am having problems
again. I can successfully purge messages in Inbox but can't seem to do so in
some of my IMAP folders.

On a related note I've also noticed that Mozilla can't get all my messages in
some folders. The status bar says 'Dowloading 1 of 71 messages' and then stops
and says done. And in reality it hasn't downloaded the messages. Purging
messages is a problem only in those folders in which this occurs. I'm attaching
a log file that I took today (11-28-2000 build).
(Reporter)

Comment 21

18 years ago
Created attachment 19869 [details]
The log file I mentioned in previous post
(Assignee)

Comment 22

18 years ago
the imap server you're using has a bug (or bugs). It's returning an invalid
envelope response (it looks like an extremely invalid envelope response to me).
I've seen other envelope problems with this imap server. I'm planning on adding
a preference to mozilla to make us not use the envelope command which will get
around this server bug.
(Assignee)

Comment 23

18 years ago
Specifically, the message-id in the envelope response,
"<200011222206.QAA14339@b04a24.exu.ericsson.se> from "Adam B. Roach" at Nov 22,
2000 04:06:18 PM"
needs to have the interior quotes escaped (the ones around Adam B. Roach). I'd
suggest contacting whoever's running the server.

Comment 24

18 years ago
I just checked RFC822 - a message ID doesn't seem to be allowed to have all the 
additional text after the < > characters. Which would put the client that sent 
it originally at fault.
(Reporter)

Comment 25

18 years ago
Okay, I sent a mail to the wensite and the webmaster replied back saying the
mail has been 'forwarded to the development team'. So I guess I'll just wait and
see. When you say the client is at fault, you mean the person who sent the email
right? I checked the headers and found that that person was using ELM as the
email client (X-Mailer:  ELM [version 2.5 PL2]).

On a different note, Mozilla seems to crash quite frequently when I check my
mail at www.myrealbox.com. Although this is not 100% reproducible, it took me 5
crashes to get the Xmailer info. Is there any way to set up a log file or
something so that I can send in the info. And what happened to the talkback
client? It never seems to pop up under Linux.
(Assignee)

Comment 26

18 years ago
yes, the original client is generating what looks like an incorrect message-id,
though I'd have to see the real message body to know for sure. But the server
should handle it, perhaps by stripping off everything after the closing '>'. I'd
be surprised, actually, if ELM was generating incorrect message-id's.

Comment 27

18 years ago
Created attachment 42550 [details]
Other IMAP log for get and delete sequence on imap.free.fr
(Assignee)

Comment 28

18 years ago
From the log, there are no deleted messages to expunge. Could you generate a log
where you delete a message, then expunge? Is it possible that you have expunge
on exit set for that server, so that we're expunging at shutdown?
(Reporter)

Comment 29

18 years ago
Created attachment 42577 [details]
Here's another test case. Same server (mailandnews.com), opened mailbox, delted 1 message, clicked on File->Compact Folders. Message still persisted and the delete mark went away.
(Assignee)

Comment 30

18 years ago
there's still no delete in that log. So we're not sending the delete flag to the
server, or logging is broken.
(Reporter)

Comment 31

18 years ago
A message was deleted. I dont know why it didn't show up in the logs. I don't
know if delete is broken bcos I can delete messages on other IMAP accounts. Is
there any way to get a more detailed log message? like maybe a log saying that
the delete button WAS indeed pressed.

Comment 32

18 years ago
In fact I was unable to see the delete action in my log 07/17/01 07:43 but I'm
SURE the delete button/menu was clicked because I saw my message aither marked
deleted (conf 1) or removed from display (conf 2, delete immediatly).
(Reporter)

Comment 33

18 years ago
bienvenu, mscott,

what do you suggest we do to give you more information about this bug. or maybe
you can open a free account on mailandnews.com and see if you get the same
behaviour.
(Reporter)

Comment 34

18 years ago
Any updates on this bug?

Comment 35

17 years ago
to points

1. There is data inconsitens between local status and imap server after netzwork
error.
2. Purge sometimes Crash Mozilla so i need to resart the browser.

Solution to point 1 File->Rrefresh-Data or Right-Click and refresh.
Refresh would semply clear the cashe and reread the server Status.

To Point 2 don't know the exact problem2

Major problem becasue
1. crash
2. data inconstitens (you can belive that text exist witch is deleted)

Updated

17 years ago
QA Contact: huang → meehansqa
(Reporter)

Comment 36

17 years ago
I reported a log for bug159267 whe I realised that the Permanentfalgs for this
particular Imap server does not include DELETED. Take a look at attachment
42577 [details]. It has these lines

36872[8cbcbe8]: mailandnews.com:A:CreateNewLineFromSocket: * FLAGS (\Draft
\Deleted \Seen \Urgent \Answered \Attach)
36872[8cbcbe8]: mailandnews.com:A:CreateNewLineFromSocket: * OK [PERMANENTFLAGS
(\Draft \Seen \Urgent \Answered \Attach)]

I tried a log with MS Exchange server and it had a \Deleted line in
PERMANENTFLAGS. Could this be the reason? Does the server not support Deleted
but Mozilla still goes ahead and tries to mark the message deleted (in the UI
atleast)?
(Assignee)

Comment 37

17 years ago
Pratik, yes, that seems to be exactly what the server is saying. That would make
this bug kinda invalid, since this is really server behaviour.
(Reporter)

Comment 38

17 years ago
bienvenu,

This exposes bug in Mozilla though. Whats the behaviour when the server doesn't
support deleted and the user selects Mark as deleted? Current behaviour. Mozilla
marks the message as deleted in the UI and when it refreshes (resyncs) with the
server, it removes the deleted mark. This is confusing to the user. If the
server does not support deleted then there should be some feedback to the user
that you can't use Mark as Deleted mode. IMO, current behaviour of silent
failure is bad.

So we can
1. Morph this bug into that, or
2. File a new bug and mark this invalid

On another note, I looked at attachment 42550 [details] and I see the following. I'm just
curious. How does Mozilla handle this?

189[3015ec0]: imap.free.fr:A:CreateNewLineFromSocket: * FLAGS (\Answered
\Flagged \Deleted \Draft \Seen)

189[3015ec0]: imap.free.fr:A:CreateNewLineFromSocket: * OK [PERMANENTFLAGS ()]
Permanent flags
(Assignee)

Comment 39

17 years ago
not really - as near as I can tell, the server supports the deleted flag,
according to the protocol log you've attached. It just doesn't support it as a
permanent flag, meaning it gets lost across sessions. It seems like an odd thing
for the server to do but...we could refuse to allow the user to delete messages
unless /DELETED is a permanent flag, but we're not doing that.

Comment 40

17 years ago
I have the problem described in the original comment.

I use Mozilla 1.1 on Windows 2000, the IMAP server is imap.online.fr.

Please help.

PS: bug 112657 seems to be a duplicate of this.

Comment 41

17 years ago
BTW, OE has the same problem with imap.online.fr but Mac OS X Mail work fine.

Comment 42

17 years ago
Reporter, can you reproduce this bug on some other servers such as UW
IMAP/Cyrus/Couriers ?
(Reporter)

Comment 43

17 years ago
I can't reproduce this bug on other servers. MS Exchange, cyrus all work fine
for me. I don't have access to UW or Courier.

Comment 44

16 years ago
I am unable to purge/delete IMAP mesages. I mark them for deletion, then upon
selecting another account, compacting folders or restarting the mail client all
messages marked for deletion become unmarked. Purging messages marked for
deletion on other mail clients successfully deletes the message.

my details:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
mail server:
Qmail 1.03 (Solaris 7 on a Sun Ultra 10)
(Assignee)

Comment 45

16 years ago
Jeffrey, could you try today's trunk build (1.3a) (I checked in a fix last night
to handle servers that incorrectly report no permanent flags). If that doesn't
work, or you don't want to download a trunk build, please attach a protocol log
by following these instructions:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

thx.
Assignee: mscott → bienvenu

Comment 46

16 years ago
I don't know if this should be posted here, but when I've deleted a message,
mozilla often just mark it as deleted, not delete it.
This is annoying since I delete unread messages, and have a mail notification
program that still says I have unread messages. I haven't found how to purge
messages yet.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021227 with Enigmail
(Assignee)

Comment 47

16 years ago
marking fixed - we now handle the case where there are no permanent flags.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.