ICE compiling <string>

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
7 months ago

People

(Reporter: pedro.lamarao, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2
Build Identifier: 

GCC 4.5 with Dehydra triggers an ICE compiling <string>.


Reproducible: Always

Steps to Reproduce:
1. Create a source file containing: #include <string>
2. Compile it with GCC 4.5 and current Dehydra

Actual Results:  
Internal Compiler Error

Expected Results:  
Successful compilation.

Using an empty script for smoke testing.
This bug is triggered by compiling <iterator> also.


[psilva@joana Mozilla]$ g++-4.5 -v
Using built-in specs.
Target: i586-redhat-linux
Configured with: ../trunk/configure --prefix=/opt/gcc-4.5 --enable-bootstrap --enable-shared --enable-threads=posix --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++ --with-ppl --with-cloog --with-tune=generic --with-arch=i586 --build=i586-redhat-linux : (reconfigured) 
Thread model: posix
gcc version 4.5.0 20090810 (experimental) (GCC) 


[psilva@joana dehydra]$ hg log -l1
changeset:   479:b30606d96357
tag:         tip
user:        Benjamin Smedberg <benjamin@smedbergs.us>
date:        Mon Aug 10 12:07:28 2009 -0400
summary:     Add SCALAR_FLOAT_TYPE_P to gcc_compat.js


g++-4.5 -O0 -g3 -Wall -c -fmessage-length=0 -fplugin=/opt/dehydra/gcc_dehydra.so -fplugin-arg-gcc_dehydra-=/home/psilva/Projetos/Mozilla/sandbox/dehydra.js -osrc/std_string.o ../src/std_string.cpp
*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event			Plugins
PLUGIN_FINISH_TYPE	gcc_dehydra 
PLUGIN_FINISH_UNIT	gcc_dehydra 
PLUGIN_CXX_CP_PRE_GENERICIZE	gcc_dehydra 
PLUGIN_FINISH	gcc_dehydra 
PLUGIN_START_UNIT	gcc_dehydra 
In file included from /opt/gcc-4.5/lib/gcc/i586-redhat-linux/4.5.0/../../../../include/c++/4.5.0/string:56:0,
                 from ../src/std_string.cpp:1:
/opt/gcc-4.5/lib/gcc/i586-redhat-linux/4.5.0/../../../../include/c++/4.5.0/bits/basic_string.tcc:1164:1: internal compiler error: tree check: expected record_type or union_type or qual_union_type, have function_decl in process_template_decl, at dehydra_plugin.c:52
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

Comment 1

9 years ago
Your dehydra isn't current.

Do hg clone http://hg.mozilla.org/rewriting-and-analysis/dehydra/ to get the latest one.  This looks like a dup of bug 499801.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
(I'm the reporter of bug 499801.)

My local repository of Dehydra is up to date, as I've shown in my bug report above:

[psilva@joana dehydra]$ hg log -l1
changeset:   479:b30606d96357
tag:         tip
user:        Benjamin Smedberg <benjamin@smedbergs.us>
date:        Mon Aug 10 12:07:28 2009 -0400
summary:     Add SCALAR_FLOAT_TYPE_P to gcc_compat.js

Comment 3

9 years ago
I'm sorry, misread that date, i'll check this out.
Blocks: 437502
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

9 years ago
seems to work now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.