Form with multiple inputs (>100) freezes the browser when and id is not used on the input

RESOLVED DUPLICATE of bug 477564

Status

()

RESOLVED DUPLICATE of bug 477564
9 years ago
9 years ago

People

(Reporter: mark, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

<div>
<input name="itemID" value="12|24">
</div>

I repeated this div 500 times with different values in the input and the browser froze periodically (3 seconds after load and every minute or so thereafter) with JS and CSS disabled.  Once I added an id to the input, the browser no longer froze.


Reproducible: Always

Steps to Reproduce:
<div>
<input name="itemID" value="12|24">
</div>

I repeated this div 500 times with different values in the input and the browser froze periodically (3 seconds after load and every minute or so thereafter) with JS and CSS disabled.
Actual Results:  
The browser froze periodically and sometimes crashed depending on the number of instances of the input.

Expected Results:  
No freezing.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564
You need to log in before you can comment on or make changes to this bug.