Created attachment 393980 [details] [diff] [review] v1 The code to get the view's nsCocoaWindow is duplicated three times, let's pull it out into a method.
Comment on attachment 393980 [details] [diff] [review] v1 The point of the delegate checking is to ensure that we get a XUL native window, not just any native window (from an embedder). This being the case, the new method is inappropriately named. It won't work in the embedding situation, it will return nsnull, and the name should reflect that. How about "GetXULNativeWindowWidget"?
You're right, the current name is no good. I think I'd prefer GetXULWindowWidget (without the "Native"), because "native window" usually means "some Cocoa object, like NSWindow*". Do you agree?
Created attachment 394212 [details] [diff] [review] v2 Same patch with new name.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.