Find As You Type Link (Apostrophe) doesn't work when dead keys are enabled

UNCONFIRMED
Unassigned

Status

()

Firefox
Keyboard Navigation
UNCONFIRMED
8 years ago
5 years ago

People

(Reporter: robbertvandendoorn, Unassigned)

Tracking

9 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; nl; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; nl; rv:1.9.0.13) Gecko/2009080315 Ubuntu/9.04 (jaunty) Firefox/3.0.13

According to this page (http://support.mozilla.com/en-US/kb/Keyboard+shortcuts) it's possible to search for text in hyperlinks using the apostrophe key. I tested this function with three different keyboard layouts:
1. German keyboard layout > It works;
2. US - International keyboard layout without dead keys > It works;
3. US - International keyboard layout with dead keys (the keyboard layout I use most of the time) > It doesn't work.

Reproducible: Always

Steps to Reproduce:
1. Ensure you use US - International with dead keys as keyboard layout;
2. Press the apastrophe key.
Actual Results:  
Nothing happens, no search bar is displayed at the bottom of the screen.

Expected Results:  
A search bar should appear at the bottom of the screen, so you could start searching for hyperlinks.

Comment 1

8 years ago
That's still the same for Firefox 3.5.5 in Ubuntu Karmic. Here I gotta press AltGr + apostrophe to quick search for links.

Comment 2

8 years ago
Same goes for songbird 1.2.0 which has the same function.

Comment 3

6 years ago
If this is still an issue:
Can you press the key twice, or press the space bar afterwards, to get the key entered?

Comment 4

6 years ago
The problem is did not change, and no, i can not get this key entered by pressing the key twice or the spacebar afterwards.
On chromium, with type-ahead-find extention this is not an issue.  

Firefox 7.0.1
Ubuntu 11.10

Comment 5

6 years ago
Thanks for the update!
Version: unspecified → 7 Branch

Comment 6

6 years ago
The problem persists on firefox 9.0.1 on linux mint 12.

I do find it may be useful to enable search as you type ("accessibility.typeaheadfind") and "accessibility.typeaheadfind.linksonly" in about:config. This workaround may be useful for some people until the bug is solved.

Updated

5 years ago
Version: 7 Branch → 9 Branch
You need to log in before you can comment on or make changes to this bug.