Menus won't stop scrolling

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Greg Miller, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have a large number of bookmarks. Frequently, when the pointer passes briefly
over the "up" arrow at the top of the bookmark menu, the menu starts to scroll
up and won't stop until I pass the mouse pointer over the arrow a second time.
I've experienced this from M17 (the first build I used with autoscrolling)
through 2000083111, which I'm using right now.
(Assignee)

Comment 1

18 years ago
nobody dies --> future
Target Milestone: --- → Future

Comment 2

18 years ago
Setting bug status to New.  Bugs whaich have been triaged to a target milestone
should not be Unconfirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
i have been annoyed by this too somewhat, but it seems to have gone away
recently. i cannot reproduce this anymore with linux build 2001040308.
(Reporter)

Comment 4

18 years ago
It still hits me all the time on NT. Maybe I should do all my browsing from my
Linux partition. ;)

Comment 5

17 years ago
Build 2001091103 on Windows ME doesn't give me this problem for the
bookmark menu, but it _does_ give me the problem for the Languages
and Fonts menus in Preferences.  Sometimes it takes a few upwards
waves of the pointer to get it to work.

Steps:
1. Edit > Preferences...
2. Navigator > Languages
3. Change the character coding to Western (ISO-8859-1).
4. Open the menu again and scroll the menu all the way to the top.
5. Place the mouse pointer below the menu and quickly move up and to the right
through the bottom of the menu.

Expect: The menu scrolls a couple lines and then stops.
Actual: The scroll continues until I move the mouse back onto one
of the arrows.
Reproduce: Almost always.

Comment 6

16 years ago
*** Bug 144133 has been marked as a duplicate of this bug. ***

Updated

16 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 7

16 years ago
Greg, your last comment on this is about a year and a half old. Do you still see
this with recent Mozilla builds?
Damian, I don't think what you saw is related to this bug.

Comment 8

16 years ago
Damian, if you were using modern theme, it could be this bug. (In classic there
are regular scrollbars, not those scroll arrows in the language preferences)
But therefore also the question to you: can you still reproduce it?
Sorry for the spam...

Comment 9

16 years ago
I can reproduce this with Linux 2002-12-07-05, modern theme.
(Reporter)

Comment 10

16 years ago
I'm still seeing it with modern on 1.2. I haven't tried a nightly in a while.

Comment 11

16 years ago
In Mozilla 2002121408 on Windows 2000 using Modern theme, I can still
reproduce the misbehavior of comment 5.

Comment 12

15 years ago
Using Mozilla app suite 1.5b1 on Windows 2000 and the modern theme, while
testing if bug 63295 was still present, I managed to trigger the misbehavior
with the bookmark menu's down arrow.  
*** Bug 293040 has been marked as a duplicate of this bug. ***
*** Bug 291893 has been marked as a duplicate of this bug. ***
*** Bug 291076 has been marked as a duplicate of this bug. ***
*** Bug 287579 has been marked as a duplicate of this bug. ***

Comment 17

13 years ago
*** Bug 298692 has been marked as a duplicate of this bug. ***

Comment 18

11 years ago
i no longer recall the bug, but this was fixed.
=> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.