elsa: error parsing __builtin_offsetof(o, f) when f is an array index expression

RESOLVED DUPLICATE of bug 506718

Status

Firefox Build System
Source Code Analysis
RESOLVED DUPLICATE of bug 506718
9 years ago
5 months ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Created attachment 394215 [details]
small test case

This comes up in spidermonkey, as |__builtin_offsetof(o, a[i])|.  See URL.
Whoops, almost forgot the error message:

cjones@beast:~[]$ /home/cjones/porky/SyncPrimitiveUpgrade.code/SyncPrimitiveUpgrade /tmp/min.ii 
In state 763, I expected one of these tokens:
  ), ., 
/tmp/min.ii:1:35: Parse error (state 763) at [

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 506718

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.