Improve advanced addon search to auto-detect user's browser, and allow sub-version specification

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Search
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Joey Twiddle, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090809 Firefox/3.5.2 (Swiftfox)
Build Identifier: 

When I perform an Advanced search on the addons site, usually I want to look for addons which will work for my browser.

I have to select Platform: "Linux" and Version: "3.5 to 3.5"

But I still get results which say "This addons is for an earlier version of Firefox"!

This may be because I am using 3.5.2 and some addons are only compatible with 3.5.0 or 3.5.1.

Therefore I would like to be able to select sub-versions in the "version" drop-down.

Or even better, the Platform and Version inputs should default to "My Current Platform" and "My Current Version", if the user's platform and Firefox version were made available in the User-Agent header.

Reproducible: Always
This might already be fixed?
Component: Public Pages → Search
QA Contact: web-ui → search
Fixed, but needs work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
I have not found any version compatibility problems when searching today.  I have found a Platform incompatibility bug however.

https://addons.mozilla.org/en-US/firefox/search?q=bear+blue&cat=2%2C0&advancedsearch=1&as=1&appid=1&lver=3.5&atype=0&pp=20&pid=2&sort=&lup=

Under 'Advanced' my platform is 'Linux', however one of the results is:

https://addons.mozilla.org/en-US/firefox/addon/8612

which is clearly marked "not available for Linux"!
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.