PDF no longer opens since last upgrade on Mac OS X

RESOLVED INVALID

Status

()

Firefox
File Handling
--
major
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: catephx, Unassigned)

Tracking

3.5 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I have used firefox for a while and have repeatedly download pdfs from common sites such as the above http://www.irs.gov/pub/irs-pdf/f1120.pdf

I am no longer able to open or download pdfs in firefox - can utilize safari and they open (and are download-able and save-able)

What happened to my wonderful firefox.  I now think this is also happening with the postage purchase program at usps.com - I first thought they were not compatible with mac, which is not unusual - but now I think it is firefox.

Reproducible: Always

Steps to Reproduce:
1.  go to website http://www.irs.gov/pub/irs-pdf/f1120.pdf
2.  hit forms and publications
3.  try to open i.e. form 1120 or 1040 - a screen opens but it is blank.  

do the same in safari and it is fine.  I have used firefox for a few years to obtain these documents and it has never failed before
Actual Results:  
a screen opens but it is blank and it says "done" in the bottom left corner

Expected Results:  
usually a screen opens as a pdf -if it is fill-in-able or a screen opens and asks if you want to open file with adobe or save it to disk.

I have used http://www.irs.gov/pub/irs-pdf/f1120.pdf

phoenix.gov - production manual

and usps.com 

to open pdfs for at least two or three years.  This does not happen in safari (FYI I do not like using safari)

Thank you!!

Comment 1

8 years ago
The current version of Adobe Reader doesn't support Firefox running on Mac OS X. Please see the Firefox Support issue link below:
http://support.mozilla.com/en-US/kb/Using+the+Adobe+Reader+plugin+with+Firefox?s=PDF

If you wish to open a PDF on Firefox browsers, you have to install the PDF Browser Plugin 2.3.1 to your System. It supports Intel or PPC Mac with Mac OS 10.4 - 10.5 and Firefox 3.0.x (also Firefox 3.5.x). 
http://www.schubert-it.com/pluginpdf/
Otherwise, install the Firefox PDF Plugin for Mac OS X from AMO.
https://addons.mozilla.org/ja/firefox/addon/7518

Comment 2

6 years ago
3.5 version is not supported anymore, plus nothing that can be done by Firefox as this is an issue that has to be solved by Adobe, or can be worked around by the instructions given in comment 1. Closing as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Summary: pdf no longer opens (therefore not download-able)since last firefox upgrade. Happens at other websites too---but they open in safari → PDF no longer opens since last upgrade on Mac OS X
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.