If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Neil Deakin, Assigned: Neil Deakin)

Tracking

(Depends on: 1 bug)

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
The resizer should have native theme capability, so that it can be used in other places besides a window, for example for bug 167951.
There's an existing patch in bug 363757.
(Assignee)

Comment 2

8 years ago
That patch seems to just draw the resizer manually, whereas I've using native growbox drawing.
Oh, good.
(Assignee)

Comment 4

8 years ago
Created attachment 394554 [details] [diff] [review]
something like this

rtl resizers don't seem to actually be drawn as such. I think the direction argument is just ignored. But we'll see how this works.

mstange, am I right in that this shouldn't impact the normal window resizer?
(Assignee)

Updated

8 years ago
Blocks: 167951
(In reply to comment #4)
> rtl resizers don't seem to actually be drawn as such. I think the direction
> argument is just ignored.

Yeah, Mac native theming doesn't care about RTL at all, it seems. Ehsan hit the same problem in bug 492217.

> mstange, am I right in that this shouldn't impact the normal window resizer?

At least as long as you don't put a xul resizer under the native resizer ;)
xul.css sets display:none on .statusbar-resizerpanel, but there might be other xul resizers outside of the statusbar somewhere in our XUL code - do you know of any occurrences?
Ah, even if there are other resizers they won't be visible because we don't set -moz-appearance: resizer on them.

So yeah, this won't impact the normal resizer at all.
Ignore my last comment. Your patch sets -moz-appearance: resizer.
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> Ignore my last comment. Your patch sets -moz-appearance: resizer.

Markus, so do you think this patch is ok?
Comment on attachment 394554 [details] [diff] [review]
something like this

Yes, I think this patch is great, with some minor adjustments:

 - I think you should remove the RTL check, since it doesn't have any effect.
 - You should probably also initialize the drawInfo's version field (to 0) in
   order to avoid UMR warnings like in bug 479716.
Attachment #394554 - Flags: review+
(Assignee)

Comment 10

8 years ago
http://hg.mozilla.org/mozilla-central/rev/64770800c4e2
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

8 years ago
Markus, to support rtl should we draw the native resizer in reverse, or draw someting manually?
See what works ;-)
IIRC HITheme doesn't really respect the transformation that you push to the context, so you might have to draw into a buffer and mirror that one (similar to what's done for scrollbars). Maybe try both and see what produces less code? ;-)
(Assignee)

Updated

8 years ago
Blocks: 514745
Depends on: 518501
(Assignee)

Updated

8 years ago
Duplicate of this bug: 115742
Depends on: 556645
You need to log in before you can comment on or make changes to this bug.