Technical Issues with Idéaliste and fr site

VERIFIED FIXED

Status

Websites Graveyard
mozillaservice.org
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
Issues:
1) Idéaliste showing up as 'Idealistas'
Issues with Idéaliste Localized names of Featured Partners aren't respecting the locale in the url

I think this is a technical bug and not a translation issue. I will try to repro.

2) Wrong links reported in Bug#500842
There are two partner links site wide. For fr they are currently:

volunteer link - http://idealist.org/if/mozservice09/fr/Home/default
organization link - http://www.idealist.org/if/mozservice09/fr/Post/Simplified/default?item-type=VolunteerOpportunity

Are you sure we want to change them to 
volunteer link - http://www.idealist.org/if/idealist/fr/Home/Splash/default
organization link - http://idealist.org/if/mozservice09/fr/Home/default

The Splash page doesn't seem to have as much call to action as the other urls.
(Reporter)

Updated

9 years ago
Blocks: 500842
(Reporter)

Comment 1

9 years ago
Repro:
1) Set language to de via the language menu
2) Go to /learn_more/volunteer/en_US directly

Actual:
Betterplace is shown

Excpected:
Idealist since Betterplace is the de featured partner

These steps also reproduce the es / fr issue noted above.
(Reporter)

Comment 2

9 years ago
Fixed r49220. The bug had to do with url's locale overriding the user's preferred locale (in cookie). We now update the featured partner when we override the locale from the url.

Marking this bug fixed. Please reopen if part #2 partner links need to change. Thanks.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
marking bug as verified fixed
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: mozillaservice.org → mozillaservice.org
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.