Cannot delete version or file after running validation

RESOLVED DUPLICATE of bug 509142

Status

--
major
RESOLVED DUPLICATE of bug 509142
9 years ago
3 years ago

People

(Reporter: gomita, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ja; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Build Identifier: 

I cannot delete a version or file with AMO Developer Tool after running validation, which is a new feature of Developer Tool.

Reproducible: Always

Steps to Reproduce:
1. Validate a XPI file with the "Validate" button, which is a new feature of AMO Developer Tool. 
2. Try to delete a version which contains the file validated by first procedure.

Actual Results:  
AMO shows a message; "Version *** is deleted successfully."
However, the version is still displayed in the versions list.
(Please see an attached file in the following my comment.)

Expected Results:  
AMO shows a message; "Version *** is deleted successfully."
And the version is actually deleted from the list.

I found another problem after having the problem above with my FireGestures extension.
I cannot find FireGestures through search https://addons.mozilla.org/en-US/firefox/search?q=FireGestures&cat=all
I suspect that this problem is related to the problem avobe.
(Reporter)

Comment 1

9 years ago
Created attachment 394502 [details]
evidence

The evidence of the problem.
Thanks for the detailed report.  This has been fixed in our trunk and will be pushed with the next update.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 509142
(Reporter)

Comment 3

9 years ago
Thanks for your quick response and sorry for my dup.

Would you tell me a thing or two?

1) When will the next update be released?

2) Will the following problem be fixed on the next update?
> I found another problem after having the problem above with my FireGestures
extension.
> I cannot find FireGestures through search
> https://addons.mozilla.org/en-US/firefox/search?q=FireGestures&cat=all
(In reply to comment #3)
> Thanks for your quick response and sorry for my dup.
> 
> Would you tell me a thing or two?
> 
> 1) When will the next update be released?
It's schedule for Aug 27th.

> 2) Will the following problem be fixed on the next update?
> > I found another problem after having the problem above with my FireGestures
> extension.
> > I cannot find FireGestures through search
> > https://addons.mozilla.org/en-US/firefox/search?q=FireGestures&cat=all

I don't know why that is happening and I don't know if it was related to this bug.  If you file a separate bug we'll investigate it.
> > 2) Will the following problem be fixed on the next update?
> > > I found another problem after having the problem above with my FireGestures
> > extension.
> > > I cannot find FireGestures through search
> > > https://addons.mozilla.org/en-US/firefox/search?q=FireGestures&cat=all
> 
> I don't know why that is happening and I don't know if it was related to this
> bug.  If you file a separate bug we'll investigate it.

Actually, it looks like this is caused by this bug.  The version application_id is null which makes the search return no results.  If you upload a new version I think this will fix itself.
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> Actually, it looks like this is caused by this bug.  The version application_id
> is null which makes the search return no results.  If you upload a new version
> I think this will fix itself.

Thanks for your investigation.
Should I still file a separate bug for this?
(Reporter)

Comment 7

9 years ago
I've just uploaded a new version and confirmed that I can now find FireGestures from the AMO's search results.
(Reporter)

Comment 8

9 years ago
Correction, I'm still not able to find FireGestures if AMO's language is English.

The URL below is OK.
https://addons.mozilla.org/ja/firefox/search?q=firegestures&cat=all

The URL below is NG.
https://addons.mozilla.org/en-US/firefox/search?q=firegestures&cat=all
If you think another bug exists please file a separate bug.  Otherwise it will just get lost in this already-resolved bug.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.