Closed Bug 510628 Opened 11 years ago Closed 10 years ago

getItemIdForGUID returns id of any attribute that happens to match the GUID

Categories

(Toolkit :: Places, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 468754

People

(Reporter: Mardak, Unassigned)

References

Details

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/src/nsNavBookmarks.cpp#291
291   rv = mDBConn->CreateStatement(NS_LITERAL_CSTRING(
292       "SELECT item_id FROM moz_items_annos "
293       "WHERE content = ?1 "
294       "LIMIT 1"),
295     getter_AddRefs(mDBGetItemIdForGUID));
296   NS_ENSURE_SUCCESS(rv, rv);

There should be a JOIN moz_anno_attributes a ON a.id = anno_attribute_id WHERE a.name = "placesInternal/GUID"
Depends on: 360134
Blocks: 554414
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468754
You need to log in before you can comment on or make changes to this bug.