Closed Bug 510686 Opened 13 years ago Closed 13 years ago

Dialogs always open minimisable, maximisable and resizable.

Categories

(Core :: Widget: Win32, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta1-fixed

People

(Reporter: neil, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(1 file)

The cleanup in bug 487245 inadvertently removed some code from WindowStyle().
Flags: blocking1.9.2?
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #394661 - Flags: review?(jmathies)
Comment on attachment 394661 [details] [diff] [review]
Restore the missing code

Well that's not good.

I wonder though if this code needs to be in wince's WindowStyle() at all. I'll track that down.

http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/nsWindowCE.cpp#307
Attachment #394661 - Flags: review?(jmathies) → review+
I don't think an sr or another r is needed for this. Neil, let me know if you need someone to land this.
Pushed changeset dbd2e6a73767 to mozilla-central.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
I think it would be safe to go ahead and push this to 1.9.2, we're just adding code that was mistakenly taken out.
Comment on attachment 394661 [details] [diff] [review]
Restore the missing code

This should be 100% safe as it is just restoring accidentally deleted code.
Attachment #394661 - Flags: approval1.9.2?
Duplicate of this bug: 509737
Flags: blocking1.9.2? → blocking1.9.2+
Attachment #394661 - Flags: approval1.9.2? → approval1.9.2+
Pushed changeset 983c31ae95a0 to releases/mozilla-1.9.2
Bah, I just realised I typoed jimm's name :-(
You need to log in before you can comment on or make changes to this bug.