firefox crashes, on restarting get update windows which are broken.

RESOLVED WORKSFORME

Status

()

Firefox
General
P2
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: himanshu, Unassigned)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1

Firefox crashes sometimes on browsing some webpages. Tabs change only with keyboard and not with mouse. On quitting firefox and restarting it , firefox says that it is doing an update. Finally a screen comes up which says that an update has to be done. On clicking the update it shows up a screen which says a license file is missing and everything is greyed out.
Attached screenshots

Reproducible: Sometimes
(Reporter)

Comment 1

9 years ago
Created attachment 394670 [details]
First 'update' window that comes when firefox is restarted after force quit
(Reporter)

Comment 2

9 years ago
Created attachment 394671 [details]
The window that comes up when clicking 'continue' button of previous attachment
(Reporter)

Comment 3

9 years ago
Would like to change in description, the line:
"On quitting firefox and restarting it , firefox
says that it is doing an update."
to
"On force quitting firefox and restarting it , firefox
says that it is installing updates."
(Reporter)

Updated

9 years ago
Severity: normal → major
Priority: -- → P2

Comment 4

9 years ago
do you crash if started in safe mode?
http://support.mozilla.com/en-US/kb/Safe+Mode
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Severity: major → critical
Keywords: crash, stackwanted
(Reporter)

Comment 5

9 years ago
Have never seen it happen with the newer firefox 3.5.5. Do I close the bug ?
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 6

9 years ago
I don't know if this reopens the bug, but this problem happens regularly with Firefox on my windows xp machine. Today, for instance, I suddenly found that I could not close tabs, nor could I switch tabs. I had two Firefox windows open, and these behaviors did not show up in the other one.

But I killed Firefox using the task manager, since it would not close by any other means, and when I reopened Firefox, I found that one of the add-ons needed to be updated. 

I've noticed this same problem over and over for months, but this is the first time I've decided to report it. When it happens, it can involve a variety of different add-ons. I have not been recording which ones, but they're not all the same.
You need to log in before you can comment on or make changes to this bug.